Graham Smith <[EMAIL PROTECTED]> writes:

> I've got a bit of a problem with a script that I make fairly
> extensive use of to create buttons for websites. It started out life
> as a GIMP-1.1 script and I upgraded it to work with GIMP-2.0 but
> have recently upgraded again to GIMP-2.2. Unfortunately this has
> broken the script (right when I need it of curse) and I can't figure
> out what is wrong.

You are using deprecated constant names (FG-IMAGE-FILL should be
FOREGROUND-FILL). I am however somewhat surprised since the old names
are still supposed to work. Try if starting gimp with the
'--pdb-compat-mode on' or '--pdb-compat-mode warn' command-line
options makes a difference.

Gimp-user mailing list

Reply via email to