I have been trying to build GIMP 2.2.0 from source, since the RPM for my OS (Redhat 9) is way out of date.

The configure command fails:
checking for GLIB - version >= 2.4.5...
*** 'pkg-config --modversion glib-2.0' returned 2.4.8, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.

I have configured, made and installed GLIB and have corrected LD_LIBRARY_PATH and PKG_CONFIG_PATH. I cannot get past this problem with the version conflicts in GLIB.

Any help will be appreciated

Gimp-user mailing list

Reply via email to