David Gowers <[EMAIL PROTECTED]> wrote:

> On 7/14/07, Olivier Lecarme <[EMAIL PROTECTED]> wrote:
> > I installed version 2.3.18 on two similar computers: Debian Sid and
> > kernel 2.6.21. The problem occurs only on one of the computers, not the
> > other. It does not occur at all with version 2.2.
> >
> > With all the tracing tools that use a brush (pencil, brush, eraser,
> > dodge and burn, etc.) but only with them, as soon as the pointer is in
> > the image window, there appears a series of images of the current brush,
> > light green. They don't modify the image itself, as simply redrawing it
> > makes the images to disappear.
> >
> > An example can be seen on http://pierredelune.i3s.unice.fr/bizarre.png
> >
> > Since this problem makes Gimp 2.3 pretty unusable for me, I would very
> > much like to find a solution. What other information would be useful?
> >
> I don't know. But this is a bug in your X server; it does not handle
> XOR drawing correctly. You may be able to configure X to work around
> the bug. You should probably ask this question on the appropriate list
> for XFree86 or X.org, whichever you are using, and provide the
> contents of the Device section for your video card (found in
> /etc/X11/XF86Config-4 or /etc/X11/Xorg.conf depending on whether you
> use XF86 or Xorg)

Maybe a bug in the X server, but then, why does it occur only in Gimp
version 2.3, not 2.2, and in no other graphic tool ? Moreover, I have
the same version of Xorg on both computers, and the problem occurs on
only one. Still moreover, is not XOR drawing used for moving the pointer
image anywhere on the screen?

Thus I'm asking what could be specific to Gimp 2.3.


                        Olivier Lecarme
Gimp-user mailing list

Reply via email to