I've been trying to set up a Git repository to replace SVN in common use for a 
project in my work place.
I wish to be able to work on a local Git repository most of the time, and 
occasionally update a centralized SVN repository with the changes.

A problem presents when I try to clone the repository using git-svn, however:
The SVN repository was poorly built, with many "tags" created not as tags, but 
as copies of the code (and binary output) files, thus resulting in enormous 
directories with many redundant files.
Most of these are no longer relevant, and I deleted them from the SVN 
repository, but I reckon they still exist in the history.

Trying to clone the repository as-is takes a *very* long time - which I 
wouldn't mind in a one-time operation, but every subsequent action (commits, 
updates and even running a simple "git status" command) takes *hours* to 
Thus I decided to try and clone only the latest revision of the repository, 
which doesn't contain all the redundant files.

This is where the subject of my question enters:
Cloning the sub-directory of the repository with the revision that I need 
doesn't fail, but it only creates the .git directory, without anything else, 
and then running "git branch -a" shows nothing - not even a master or trunk 
Trying to run "git svn rebase" fails with the error:
"fatal: ambiguous argument 'HEAD': unknown revision or path not in working tree.
Use '--' to separate paths from revisions
rev-list --first-parent --pretty=medium HEAD: command returned error: 128"

After searching online I've found several sources all saying that this is 
caused by using the '-s' argument to clone a repository whose layout isn't 
standard, but the sub-directory of the repository I'm trying to clone *does* 
contain the standard SVN layout.
I've tried specifying the paths of the trunk, tags and branches folders 
specifically to their corresponding subdirectory names, as well as to their 
full paths, but the result is the same each time.
The directory I'm trying to clone isn't at the root of the repository, so I 
also tried using the '--no-minimize-url' argument to prevent climbing up the 
folder tree, again to no effect.

Cloning the directory that contains the trunk/tags/branches folders without 
specifying the '-s' option clones it successfully, but treats the SVN layout 
folders as regular directories (the whole tree goes into the master branch).

I'm using Git version 1.7.10.msysgit.1 on a Windows XP platform.

Any help in resolving this matter would be highly appreciated.

Thank you for your patience in reading this long problem description,

And have a nice day,

Tomer Godinger.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To view this discussion on the web visit 
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to