Thanks for the swift reply.

The basic command I tried to use was:
git svn clone -r9999 --stdlayout --preserve-empty-dirs 
http://MyRepoAddress/Some/Dirs/MyDir .

Where 9999 stands for the revision I want, "MyDir" is the name of the directory 
I'm trying to get, and the rest of the address is the path leading up to it.
The " ." at the end was to make it use the current directory, but the same 
thing happened without it (only in a subdirectory).
As I've mentioned, I have also tried running the command with --no-minimize-url 
and with -T/-t/-b with relative and full paths.

Regarding the structure of my SVN, let's assume I'm trying to get the MyDir 
directory under repo/a/b - in that case, my folder structure looks something 
like this:
- repo
    - somedirs
    - a
        - somedirs
        - b
            - somedirs
            - MyDir
                - branches
                    - branch1
                    - branch2
                    - branch3
                - tags
                    - tag1
                    - tag2
                    - tag3
                    - tag4
                    - tag5
                - trunk
                    - codedir1
                    - codedir2
                    - ...

The contents of trunk resemble the contents of each branch and tag (there may 
be differences since files are added and removed during development, but the 
point is that there aren't any intermediary folders; each tag is identical to 
the trunk at the time of its making).
Furthermore, there are no other folders under MyDir beyond trunk, tags and 
branches (though there used to be a text file there as well).

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To view this discussion on the web visit 
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to