Hi all,
This is going to be a longish one, so please pull up a chair.

I'm trying to get a repository . The repo. is
https://github.com/clintbellanger/flare-game . Now I'm on a unstable
network so first I tried the classical way :-

$ git clone --depth=1 https://github.com/clintbellanger/flare-game.git
Cloning into 'flare-game'...
remote: Counting objects: 2731, done.
remote: Compressing objects: 100% (2474/2474), done.
Killeding objects:  17% (470/2731), 134.73 MiB | 57.00 KiB/s

My network went down and I had to kill the running process because
when the network came back git didn't start from where it had let off.

So I did the following :-

Code: Select all
    ~/games/flare-game$ git fetch --depth=1
remote: Counting objects: 2735, done.
remote: Compressing objects: 100% (2477/2477), done.
remote: Total 2735 (delta 331), reused 2401 (delta 239)
Receiving objects: 100% (2735/2735), 353.25 MiB | 53.00 KiB/s, done.
Resolving deltas: 100% (331/331), done.
>From https://github.com/clintbellanger/flare-game
   * [new branch]      master     -> origin/master

Now I tried to unshallow the repo.

~/games/flare-game$ git fetch --unshallow
remote: Counting objects: 29729, done.
remote: Compressing objects: 100% (9191/9191), done.
Receiving objects:  46% (13271/28465), 124.33 MiB | 58.00 KiB/s

I went to ~/games/flare-game/.git/objects/pack and saw this :-

$ ll -h
    total 396M
    -r--r--r-- 1 shirish shirish  76K Aug 25 15:46
    -r--r--r-- 1 shirish shirish 354M Aug 25 15:46
    -r--r--r-- 1 shirish shirish  43M Aug 25 16:47 tmp_pack_BLnuHj

If I remove the last tmp file and try git fsck and git gc I get the following :-

    ~/games/flare-game$ git fsck
    notice: HEAD points to an unborn branch (master)
    Checking object directories: 100% (256/256), done.
    Checking objects: 100% (2735/2735), done.

as well as :-

~/games/flare-game$ git gc
 Counting objects: 2735, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (2385/2385), done.
Writing objects: 100% (2735/2735), done.
Total 2735 (delta 331), reused 2735 (delta 331)

If I now do :-

~/games/flare-game$ git fetch --unshallow

Would it give me the other 100/150 MB remaining without re-downloading
the whole 350 MB again i.e. just the diff.? The repo. is supposedly
around 500/600 MB .

Looking forward for some clarity.
          Shirish Agarwal  शिरीष अग्रवाल
  My quotes in this email licensed under CC 3.0
065C 6D79 A68C E7EA 52B3  8D70 950D 53FB 729A 8B17

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to