for my mingwGitDevEnv project [1] I'm currently looking at the failing
Git tests [2]. The first tests that fails is t0060-path-utils [3]:

not ok 88 - relative path: / /a/b/ => ../../
# test "$(test-path-utils relative_path '/' '/a/b/')" = '../../'

not ok 91 - relative path: /x/y /a/b/ => ../../x/y
# test "$(test-path-utils relative_path '/x/y' '/a/b/')" = '../../x/y'

If I run "test-path-utils relative_path '/' '/a/b/'" on the server
(running Windows Server 2008 R2) that perform the testing I indeed

$ test-path-utils relative_path '/' '/a/b/'
$ pwd -W

The funny thing is, if I run the exact same binary on my local Windows
8 64-bit machine I get the expected result:

$ test-path-utils relative_path '/' '/a/b/'
$ pwd -W

So how can the exact same test-path-utils binary create different
results fo the same arguments? I'd be very grateful for any insights.
If you want to play around with it yourself, you can download the
while Jenkins workspace as a ZIP at [4] (but note that it's almost 1

It's probably also interesting to mention that t0060-path-utils did
not yet fail in build 38 [5] and I'm currently in the process to find
out what changed.

[1] https://github.com/sschuberth/mingwGitDevEnv/
[2] http://mingwgitdevenv.cloudapp.net/job/mingwGitDevEnv-test/42/
[5] http://mingwgitdevenv.cloudapp.net/job/mingwGitDevEnv-test/38/

Sebastian Schuberth
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to