On 8/22/19 14:40, Willy Tarreau wrote:
>> I would suggest naming it something like fc_authority or
>> fc_pp_authority, to be specific about where it came from.

Since you used fc_pp_authority in an example further down, I'll take
that as the choice (unless somebody yells). Seems better to me, since
just "authority" could refer to a number of things.

> You don't need to have the extra boolean because our sample fetch functions
> already return this information for you. The "-m found" match method
> indicates whether or not the requested information was present, regardless
> of its possible emptiness.
>> I assume the fetch for the authority TLV should return the empty string
>> if none was read; correct?
> No it returns a "not found" (return 0 technically speaking).

Ah, OK thx.

>> - Use a dedicated memory pool to allocate the name from TLV, if there is
>> one in the proxy header.
> Yep. Please name it "authority" then. At least if we need an authority
> anywhere else we know we can share it.


All right, I think we've covered enough that I can take another go at
coding it up. And I believe I can mail a patch next time, if there are
no objections. Since the patch will be adding a fetch, I'd say the
regression risk is MINOR, as no one could have ever used it before.

Willy, thanks again for the feedback, the first impression about working
with haproxy development has been very pleasant.

** * * UPLEX - Nils Goroll Systemoptimierung

Scheffelstra├če 32
22301 Hamburg

Tel +49 40 2880 5731
Mob +49 176 636 90917
Fax +49 40 42949753


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to