On Thu, Aug 22, 2019 at 04:33:13PM +0200, Geoff Simmons wrote: > On 8/22/19 14:40, Willy Tarreau wrote: > > > >> I would suggest naming it something like fc_authority or > >> fc_pp_authority, to be specific about where it came from. > > Since you used fc_pp_authority in an example further down, I'll take > that as the choice (unless somebody yells). Seems better to me, since > just "authority" could refer to a number of things.
OK. > All right, I think we've covered enough that I can take another go at > coding it up. And I believe I can mail a patch next time, if there are > no objections. Since the patch will be adding a fetch, I'd say the > regression risk is MINOR, as no one could have ever used it before. If it's really *that* minor (we'll see in the end), we could even think about backporting it to 2.0. We do occasionally backport a few sample fetches and converters when they are totally harmless. And if your work on Varnish is about to be completed, you could benefit from the full support from a stable version. > Willy, thanks again for the feedback, the first impression about working > with haproxy development has been very pleasant. Thanks. Willy