Ralf Muschall wrote:

>  And if I call the label on the stones "integer_from_string"
>  and "integer_from_intlist", unflipped (.) does as well.

But then the question is which function name is more natural.
Arjen's choice of names reflects Haskell's syntax for function
types:

         intlist_to_integer
     ::   [Int]  -> Integer

Or look at o's and flippo's types:

     (.)      :: ((a -> b) -> (c -> a)) -> (c -> b)
     flip (.) :: ((a -> b) -> (b -> c)) -> (a -> c)

Surely the second one is much cooler!


Cheers,

Ronny Wichers Schreur


Reply via email to