Chris Wilson <ch...@chris-wilson.co.uk> writes:
> Quoting Tvrtko Ursulin (2018-02-08 14:34:38)
>> On 08/02/2018 14:22, Ville Syrjälä wrote:
>> > On Thu, Feb 08, 2018 at 01:06:05PM +0000, Tvrtko Ursulin wrote:
>> >> From: Tvrtko Ursulin <tvrtko.ursu...@intel.com>
>> >> Coccinelle transformation:
>> >> @@
>> >> expression p, g;
>> >> @@
>> >> (
>> >> -INTEL_GEN(p) > g
>> >> +IS_GEN_GT(p, g)
>> > I think this stuff makes the code pretty close to illegible.
>> > In this particular case even more so because "GT" actually
>> > means something very different to us.
>> Oh how true! And I did not realize it at all while writing it! :)
>> Anyway, something like this, regardless of a name, is needed if people
>> want this to be effective. Since the checks have to be moved to known at
>> compile time. Or a completely different approach will be needed.
> IS_GEN_RANGE() doesn't cut it?
short and readable
> I think that people find it inconvenient to use, so some sugar is still
> Intel-gfx mailing list
Intel-gfx mailing list