On Tue, Jun 28, 2022 at 07:53:39PM +0800, Baolu Lu wrote: > > > > Once the iopf_handle_single() is removed, the name of > > > > iopf_handle_group() looks a little weired > > > > > > > > and confused, does this group mean the iommu group (domain) ? > > > > while I take some minutes to > > > > > > No. This is not the iommu group. It's page request group defined by the > > > PCI SIG spec. Multiple page requests could be put in a group with a > > > same group id. All page requests in a group could be responded to device > > > in one shot. > > > > Thanks your explaination, understand the concept of PCIe PRG. I meant > > > > do we still have the necessity to mention the "group" here in the name > > > > iopf_handle_group(), which one is better ? iopf_handle_prg() or > > > > iopf_handler(), perhaps none of them ? :) > > Oh! Sorry for the misunderstanding. > > I have no strong feeling to change this naming. :-) All the names > express what the helper does. Jean is the author of this framework. If > he has the same idea as you, I don't mind renaming it in this patch.
I'm not attached to the name, and I see how it could be confusing. Given that io-pgfault is not only for PCIe, 'prg' is not the best here either. iopf_handle_faults(), or just iopf_handler(), seem more suitable. Thanks, Jean _______________________________________________ iommu mailing list email@example.com https://lists.linuxfoundation.org/mailman/listinfo/iommu