[ 
https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12703660#action_12703660
 ] 

Marvin Humphrey commented on LUCENE-1614:
-----------------------------------------

> nudge doesn't sound like it changes anything, but just "touches".

If you say so.  In Lucy, I expect we'll use "next" and "advance".  

> if distinct method names is what we're after

Yes, that's the idea.  These two methods are very different from each other.
The official definition of skipTo() has many subtle gotchas.  Just because
they both move the iterator forward doesn't mean they do the same thing, and
it is cumbersome and taxing to have to differentiate between methods using
long-form signatures in the midst of standard prose.

There's no good reason to conflate these two methods, just as there's no 
good reason why we should be forced to write "search(Collector)" instead
of "collect()" or "collectHits()".

> I prefer nextDoc() and skipToDoc() or advance() for the latter. 

IMO, "advance" more accurately describes what that method does than either
"skipTo" or "skipToDoc".  The problem is that if you're on doc 10, then
skipToDoc(10) doesn't, in fact, skip to doc 10 as the method name implies --
it takes you to at least doc 11.  Furthermore, "advance" reinforces that you
can only seek forwards.


> Add next() and skipTo() variants to DocIdSetIterator that return the current 
> doc, instead of boolean
> ----------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-1614
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1614
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>
>
> See 
> http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html
>  for the full discussion. The basic idea is to add variants to those two 
> methods that return the current doc they are at, to save successive calls to 
> doc(). If there are no more docs, return -1. A summary of what was discussed 
> so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI 
> (calls next() and skipTo() respectively, and will be changed to abstract in 
> 3.0).
> #* I actually would like to propose an alternative to the names: advance() 
> and advance(int) - the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead 
> of comparing to -1 for improved performance.
> I will post a patch shortly

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to