[ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12704631#action_12704631 ]
Michael McCandless commented on LUCENE-1614: -------------------------------------------- bq. I mean, instead of having the code call check(8), get true and then advance(8), just call checkAndAdvance(8) which returns true if 8 is supported and false otherwise, AND moves to 8. Oh, sorry: that's in fact what I intended check to do. But by "moves to 8" what it really means is "you now cannot call check on anything < 8 (maybe 9)" I think after check(N) is called, one cannot call doc() -- the results are not defined. So check(N) logically puts the iterator at N, and you may at that point call next if you want, or call another check(M) but you cannot call doc() right after check. bq. So should I add this check()? I think so? We can then do perf tests of that vs filter-as-BooleanClause? > Add next() and skipTo() variants to DocIdSetIterator that return the current > doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > > See > http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html > for the full discussion. The basic idea is to add variants to those two > methods that return the current doc they are at, to save successive calls to > doc(). If there are no more docs, return -1. A summary of what was discussed > so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI > (calls next() and skipTo() respectively, and will be changed to abstract in > 3.0). > #* I actually would like to propose an alternative to the names: advance() > and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead > of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail: java-dev-h...@lucene.apache.org