[ 
https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12704462#action_12704462
 ] 

Shai Erera commented on LUCENE-1614:
------------------------------------

bq. I mean the scorer should go straight to the doc I asked for and test 
whether it accepts that doc and do nothing else.

Just to clarify for myself, in the example I gave above, suppose thar the 
scorer is on "3" and you call check(8). Do you expect it to go to 10, realize 
that 8 is not supported and go back to 3? Can it be called with check(7) 
afterwards? If not, then why not use advance(8), get back 10 and realize 8 is 
not supported? You should be able to call advance(9) without it advancing 
beyond 10 (which it's currently on).

Your comment on TermScorer just reinforces my confusion - what is this API good 
for, and what's missing in advance(target) today? Can't ConjunctionScorer call 
advance until it gets a response which is not what was asked for?

> Add next() and skipTo() variants to DocIdSetIterator that return the current 
> doc, instead of boolean
> ----------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-1614
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1614
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>
>
> See 
> http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html
>  for the full discussion. The basic idea is to add variants to those two 
> methods that return the current doc they are at, to save successive calls to 
> doc(). If there are no more docs, return -1. A summary of what was discussed 
> so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI 
> (calls next() and skipTo() respectively, and will be changed to abstract in 
> 3.0).
> #* I actually would like to propose an alternative to the names: advance() 
> and advance(int) - the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead 
> of comparing to -1 for improved performance.
> I will post a patch shortly

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to