[ 
https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12704522#action_12704522
 ] 

Shai Erera commented on LUCENE-1614:
------------------------------------

I think I understand what you mean, but please correct me if I'm wrong. You 
propose this check() so that in case a DISI can save any extra operations it 
does in next() (such as reading a payload for example) it will do so. Therefore 
in the example you give above with CS, next()'s contract forces it to advance 
all the sub-scorers, but with check() it could stop in the middle.

This warrants an explicit documentation and implementation by current DISIs ... 
I don't think that if you call a DISI today with next(10) and next(10) it will 
not move to 11 in the second call. But calling check(10) and next(10) MUST not 
advance the DISI further than 10. If the default impl in DISI just uses 
nextDoc() and returns true if the return value is the requested, we should be 
safe back-compat-wise, but this is still dangerous and we need clear 
documentation.

BTW, perhaps a testAndSet-like version can save check(10) followed by a 
next(10), and will fit nicer?

> Add next() and skipTo() variants to DocIdSetIterator that return the current 
> doc, instead of boolean
> ----------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-1614
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1614
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>
>
> See 
> http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html
>  for the full discussion. The basic idea is to add variants to those two 
> methods that return the current doc they are at, to save successive calls to 
> doc(). If there are no more docs, return -1. A summary of what was discussed 
> so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI 
> (calls next() and skipTo() respectively, and will be changed to abstract in 
> 3.0).
> #* I actually would like to propose an alternative to the names: advance() 
> and advance(int) - the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead 
> of comparing to -1 for improved performance.
> I will post a patch shortly

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to