Despite a quick runthrough from Jesse Glick at Jenkins World, I'm bumping 
up against two different blockers trying to use an SVN repo as an external 
global library repository with Pipeline.

All plugins are up to date, and the master is running LTS 2.7.4 on Windows.

In all attempts the script begins with

@Library('pipeline-global-helpers') _


@Library('pipeline-global-helpers@trunk') _

Neither variant made a difference.

*First Try*
This seems like the most logical configuration, with the version token in 
the *Repository URL*.

But on running the script, the token is interpreted as a literal and the 
checkout fails:

*Second Try*This configuration didn't make a lot of sense but I just 
spelled out the *Repository URL* literally and put the token in the *Default 
version* field:

And strangely enough it sort of worked. It checked out the code, but then 
could not find the subdirectories that are clearly present.

*Third Try*Similar to the second try, I put the token in another 
questionable field and got the same result as the second try.

Can anybody see what I am doing wrong? I feel like I'm missing something 
elementary, as Jesse Glick has tested this enhancement with an SVN repo.


You received this message because you are subscribed to the Google Groups 
"Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to