bruns added a comment.
I think the patch as is has some structural problems. I think it would be significantly cleaner when: - the "cacheAllowed" checking code is moved into a separate function - the global `allowCache` variable is removed, and the value is passed into `createSubThumbnail(...)`/`drawSubThumbnail(...)` as parameter You can then call the check function once on the directory, at the same place the `QDirIterator` is instantiated (line 538). And can you please use `arc` for uploading the patch, it is really hard to do a review without context. REPOSITORY R320 KIO Extras REVISION DETAIL https://phabricator.kde.org/D28745 To: marcingu, ivan, broulik, #dolphin, ngraham, meven, bruns Cc: thiago, bruns, meven, ngraham, kde-frameworks-devel, kfm-devel, waitquietly, azyx, nikolaik, pberestov, iasensio, aprcela, fprice, LeGast00n, cblack, fbampaloukas, alexde, Codezela, feverfew, michaelh, spoorun, navarromorales, firef, andrebarros, emmanuelp, rdieter, mikesomov