Can You post some hi rez pictures of board ?

LAN is working on my U-Boot ?



W dniu 2016-10-04 o 21:59, Juan Rios pisze:
Hello again. Thanks to borderline at
I could install the ZyXEL P-2812HNU-F1 uboot and I can boot into it.

What I did was shortcut the flash pins like described here till I
got the VR9 prompt and
then used U -> 0 and uploaded via xmodem the file

With that installed this is the bootlog

ROM VER: 1.1.4
CFG 06

U-Boot SPL 2013.10-openwrt5 (Nov 18 2014 - 19:54:01)
SPL: initializing NAND flash
SPL: checking U-Boot image
SPL: loading U-Boot to RAM
SPL: decompressing U-Boot with LZO
SPL: jumping to U-Boot

U-Boot 2013.10-openwrt5 (Nov 18 2014 - 19:54:01) P-2812HNU-Fx

Board: ZyXEL P-2812HNU-Fx
SoC:   Lantiq VRX288 v1.2
CPU:   500 MHz
IO:    250 MHz
BUS:   250 MHz
DRAM:  256 MiB
NAND:  128 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ltq-eth
Hit any key to stop autoboot:  0
Wrong Image Format for bootm command
ERROR: can't get kernel image!
P-2812HNU-Fx #

How can I get the information to make a proper .dts file for this
device ? The layout of the flash for the P-2812HNU-Fx has nothing to
do with this device.

     Area            Address      Length
[0] Boot            0x00000000    1024K
[1] Image 0         0x00100000   10240K
[2] Image 1         0x00B00000   10240K
[3] Configuration   0x01500000    2048K
[4] Boot Params     0x01700000    2048K
[5] Nvram           0x01900000    1024K
[6] Cert            0x01A00000   32768K
[7] EmergencyValue  0x03A00000    6144K
[8] Configuration2  0x04000000    2048K
[9] All area        0x00000000   67584K

On Mon, Aug 29, 2016 at 10:49 PM, Mathias Kresin <> wrote:
28.08.2016 13:24, Mathias Kresin:

Am 28.08.2016 um 12:15 schrieb Hauke Mehrtens:
On 08/28/2016 10:31 AM, Mathias Kresin wrote:
Am 27.08.2016 um 19:44 schrieb Juan Rios:
I can load to memory using xmodem transfer and run but all I tried get
locked without any output.

Have you tried the kenrel with both serial interfaces? The SoC supports
two and I do not know which on is used on your hardware.

@Mathias is it normal that this does not work?

Mhh, I've missed that part of Juans mail. It's not clear to me what Juan
tried to load and run from ram.

Loadx and run the kernel from ram is a brilliant idea. Albeit I've done
it dozen times with u-boot, I never considered doing the same with

I might have some time later the day to give it a try.

I couldn't manage to start an uncompressed LEDE kernel from ram. I've tried
kernels with brncmdline and without. But the router immediately resets

Running the uncompressed recovery kernel from ram worked however.


Lede-dev mailing list

Lede-dev mailing list

Reply via email to