A big caveat:

GammaRay requires PyQt 5.10 to work. I can build it and use it to load Leo 
and it works great. Very useful.

But PyQt 5.10 breaks my stylesheet. Qt Designer validates the stylesheet 
just fine. Drop back to PyQt 5.6.2 and the stylesheet renders correctly in 
Leo. All things considered, I blame PyQt. :-)

Is there anything we can do to have Leo support 5.10? This is the second 
time that I have had an app *require* PyQt 5.10.


On Sunday, March 11, 2018 at 1:25:46 PM UTC-7, Chris George wrote:
> Thanks for the motivation. I am now running GammaRay and Leo native (no 
> Anaconda). I will have to rebuild a few things, but no big deal.
> Leo Log Window
> Leo 5.8 devel, build 20180307231313, Wed Mar 7 23:13:13 PST 2018
> Git repo info: branch = devel, commit = 0a733e0506cd
> Python 3.6.4, PyQt version 5.10.0
> linux
> isPython3: True
> Chris

You received this message because you are subscribed to the Google Groups 
"leo-editor" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to leo-editor+unsubscr...@googlegroups.com.
To post to this group, send email to leo-editor@googlegroups.com.
Visit this group at https://groups.google.com/group/leo-editor.
For more options, visit https://groups.google.com/d/optout.

Reply via email to