https://bugs.documentfoundation.org/show_bug.cgi?id=115642

--- Comment #15 from mich...@alzetta.org ---
In the example spreadsheet I uploaded, the formula in A7 is = A1+A2+A3+A4+A5+A6
and in Aron Budea's spreadsheet this gives #VALUE! whereas in mine it gives the
correct result (as you can see from screenshots)

The formula in B7 is =SOMMA(B1:B6) and it only sums the one value which is
correctly formatted as a number, disregading the others. 

So, for some reason, (localization?) in my version of Calc the wrongly
formatted numbers are summed in the A7 formula but correctly disregarded in the
B7 formula.

In my case the wrongly formatted numbers can ony be seen by removing direct
formatting, and in this case the ' appears before the number like this '0,00456

I have no idea how such numbers were actually inserted to start with (maybe
copying a number from text and pasting it?) 

I think you can reproduce this as follows:
1) create a column of numbers
2) remove direct formatting, then manually add the ' character before some of
them, and save
3) at this point the file you have is like mine. On my version of Calc summing
the cells should still work whereas on yours it should give #VALUE!

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Libreoffice-bugs mailing list
Libreoffice-bugs@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/libreoffice-bugs

Reply via email to