HPAGE_SIZE and HPAGE_SHIFT macro is written based on the 4KB PAGE_SIZE.
When this macro is used in some test, test result would be strange in
the system where PAGE_SIZE is more then 4KB.
Here is the example with transhuge-stress test with 16KB PAGE_SIZE:
transhuge-stress: allocate 61073 transhuge pages, using 122146 MiB virtual
memory and 1908 MiB of ram
3.292 s/loop, 0.054 ms/page, 37106.002 MiB/s 2566 succeed, 58507
failed, 2566 different pages
0.591 s/loop, 0.010 ms/page, 206850.792 MiB/s 0 succeed, 61073
failed, 0 different pages
0.527 s/loop, 0.009 ms/page, 231895.107 MiB/s 0 succeed, 61073
failed, 0 different pages
3.292 s/loop, 0.054 ms/page, 37106.002 MiB/s 2566 succeed, 58507
failed, 2566 different pages
0.591 s/loop, 0.010 ms/page, 206850.792 MiB/s 0 succeed, 61073
failed, 0 different pages
0.527 s/loop, 0.009 ms/page, 231895.107 MiB/s 0 succeed, 61073
failed, 0 different pages
0.527 s/loop, 0.009 ms/page, 231839.704 MiB/s 0 succeed, 61073
failed, 0 different pages
0.528 s/loop, 0.009 ms/page, 231544.782 MiB/s 0 succeed, 61073
failed, 0 different pages
0.528 s/loop, 0.009 ms/page, 231462.074 MiB/s 0 succeed, 61073
failed, 0 different pages
0.527 s/loop, 0.009 ms/page, 231770.300 MiB/s 0 succeed, 61073
failed, 0 different pages
...
ok 1 Completed
To address this, remove the HPAGE_SIZE and HPAGE_SHIFT macro,
introduce pmd_pshift() and rename read_pmd_pagesize() to pmd_psize()
to keep consistency with psize() and pshift().
Also, run the KSM_MERGE_TIME_HUGE_PAGES test with a size of 512 MiB,
which is the least common multiple of the PMD sizes for 4 KiB, 16 KiB,
and 64 KiB base pages. Since allocate_transhuge() allocates mappings in
PMD-sized units, the test may fail with the previous size of 100 MiB,
which is not a multiple of the PMD size when the base page size is
16 KiB or 64 KiB.
After this patch, output of transhuge-stress:
transhuge-stress: allocate 3817 transhuge pages, using 122146 MiB virtual
memory and 119 MiB of ram
2.558 s/loop, 0.670 ms/page, 47755.759 MiB/s 2585 succeed, 1232
failed, 2585 different pages
2.640 s/loop, 0.692 ms/page, 46268.432 MiB/s 2585 succeed, 1232
failed, 2585 different pages
2.635 s/loop, 0.690 ms/page, 46360.298 MiB/s 2585 succeed, 1232
failed, 2585 different pages
2.782 s/loop, 0.729 ms/page, 43899.795 MiB/s 2616 succeed, 1201
failed, 2616 different pages
2.692 s/loop, 0.705 ms/page, 45380.876 MiB/s 2627 succeed, 1190
failed, 2627 different pages
2.612 s/loop, 0.684 ms/page, 46765.812 MiB/s 2628 succeed, 1189
failed, 2628 different pages
2.683 s/loop, 0.703 ms/page, 45520.990 MiB/s 2630 succeed, 1187
failed, 2630 different pages
2.727 s/loop, 0.714 ms/page, 44789.321 MiB/s 2631 succeed, 1186
failed, 2631 different pages
...
ok 1 Completed
Additionally, introduce size_to_shift() for future users that need to
obtain shift of a huge-page which is other than pmd_psize().
Patch History
=============
Change in v3:
- rename read_pmd_pagesize() to pmd_psize()
- introduce size_to_shift()
- Link to v2:
https://lore.kernel.org/all/[email protected]/
Chnage in v2:
- rename hpage_* to pmd_page_*
- Link to v1:
https://lore.kernel.org/all/[email protected]/#t
---
Yeoreum Yun (3):
kselftest: mm: rename read_pmd_pagesize() to pmd_psize()
kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
kselftest: mm: introduce size_to_shift() helper
tools/testing/selftests/mm/cow.c | 2 +-
tools/testing/selftests/mm/folio_split_race_test.c | 2 +-
tools/testing/selftests/mm/guard-regions.c | 11 ++++-
tools/testing/selftests/mm/hmm-tests.c | 22 ++++-----
tools/testing/selftests/mm/khugepaged.c | 2 +-
tools/testing/selftests/mm/ksm_tests.c | 16 ++++---
tools/testing/selftests/mm/migration.c | 4 +-
tools/testing/selftests/mm/mkdirty.c | 2 +-
tools/testing/selftests/mm/pagemap_ioctl.c | 2 +-
tools/testing/selftests/mm/prctl_thp_disable.c | 4 +-
tools/testing/selftests/mm/process_madv.c | 2 +-
tools/testing/selftests/mm/run_vmtests.sh | 4 +-
tools/testing/selftests/mm/soft-dirty.c | 2 +-
tools/testing/selftests/mm/split_huge_page_test.c | 2 +-
tools/testing/selftests/mm/transhuge-stress.c | 25 ++++++-----
tools/testing/selftests/mm/uffd-common.c | 6 +--
tools/testing/selftests/mm/uffd-unit-tests.c | 8 ++--
tools/testing/selftests/mm/uffd-wp-mremap.c | 2 +-
tools/testing/selftests/mm/vm_util.c | 52 ++++++++++++++++++----
tools/testing/selftests/mm/vm_util.h | 12 +++--
20 files changed, 116 insertions(+), 66 deletions(-)
---
base-commit: 6b41451631cabf9ea3b384c2a099088e1598f963
change-id: 20260909-fix_hpage_macro-da069ae04502
Best regards,
--
Sincerely,
Yeoreum Yun