On Tue, Sep 22, 2026 at 06:12:29PM +0100, Muhammad Usama Anjum wrote: > pte_t is used both for software PTE values and for entries stored in a PTE > table, so pte_t * does not distinguish a pointer to a software PTE > value from a pointer to table storage. > > Introduce hw_pte_t as the generic name for a PTE table element. Define it > as a macro alias of pte_t by default. When an architecture selects > ARCH_HAS_HW_PTE_T, define it as a structure containing a pte_t instead. > This preserves the representation while allowing converted architectures > to enforce the distinction at compile time. > > Name the generic wrapper structure __hw_pte_t so architectures can > forward-declare it when pgtable_t must be defined before the generic > hw_pte_t typedef is visible. This avoids header-order dependencies. > > Keep the C type definitions behind an __ASSEMBLY__ check because > architecture assembly sources can include this header indirectly. Include > asm/page.h so consumers such as linux/vmalloc.h retain the page definitions > they previously obtained from that header. > > Acked-by: David Hildenbrand (Arm) <[email protected]> > Signed-off-by: Muhammad Usama Anjum <[email protected]>
LGTM Reviewed-by: Anshuman Khandual <[email protected]> > --- > Changes since v1: > - Name the generic wrapper structure __hw_pte_t so architectures can > forward-declare it, and explain why this is required. > - Use software PTE value terminology. > > Changes since RFC v1: > - Add the ARCH_HAS_HW_PTE_T opt-in and generic wrapper definition. > - Exclude the C type definitions from assembly sources. > - Update the description for the new opt-in model. > --- > MAINTAINERS | 1 + > include/linux/pgtable_types.h | 17 +++++++++++++++++ > mm/Kconfig | 3 +++ > 3 files changed, 21 insertions(+) > > diff --git a/MAINTAINERS b/MAINTAINERS > index 2133aec4a2004..da60a8bdcddb5 100644 > --- a/MAINTAINERS > +++ b/MAINTAINERS > @@ -17140,6 +17140,7 @@ F: include/linux/mmu_notifier.h > F: include/linux/pagewalk.h > F: include/linux/pgalloc.h > F: include/linux/pgtable.h > +F: include/linux/pgtable_types.h > F: include/linux/ptdump.h > F: include/linux/vmpressure.h > F: include/linux/vmstat.h > diff --git a/include/linux/pgtable_types.h b/include/linux/pgtable_types.h > new file mode 100644 > index 0000000000000..07da05d375c2c > --- /dev/null > +++ b/include/linux/pgtable_types.h > @@ -0,0 +1,17 @@ > +/* SPDX-License-Identifier: GPL-2.0 */ > +#ifndef _LINUX_PGTABLE_TYPES_H > +#define _LINUX_PGTABLE_TYPES_H > + > +#include <asm/page.h> > + > +#ifndef __ASSEMBLY__ > + > +#ifdef CONFIG_ARCH_HAS_HW_PTE_T > +typedef struct __hw_pte_t { pte_t __pte; } hw_pte_t; > +#else > +#define hw_pte_t pte_t > +#endif > + > +#endif /* !__ASSEMBLY__ */ > + > +#endif /* _LINUX_PGTABLE_TYPES_H */ > diff --git a/mm/Kconfig b/mm/Kconfig > index c1ddf59c0d71a..5f462ec6fa5e5 100644 > --- a/mm/Kconfig > +++ b/mm/Kconfig > @@ -1312,6 +1312,9 @@ comment "GUP_TEST needs to have DEBUG_FS enabled" > config GUP_GET_PXX_LOW_HIGH > bool > > +config ARCH_HAS_HW_PTE_T > + bool > + > config DMAPOOL_TEST > tristate "Enable a module to run time tests on dma_pool" > depends on HAS_DMA > > -- > 2.47.3 >
