On 22 Sep 2026, at 13:12, Muhammad Usama Anjum wrote: > pte_t is used both for software PTE values and for entries stored in a PTE > table, so pte_t * does not distinguish a pointer to a software PTE > value from a pointer to table storage. > > Introduce hw_pte_t as the generic name for a PTE table element. Define it > as a macro alias of pte_t by default. When an architecture selects > ARCH_HAS_HW_PTE_T, define it as a structure containing a pte_t instead. > This preserves the representation while allowing converted architectures > to enforce the distinction at compile time. > > Name the generic wrapper structure __hw_pte_t so architectures can > forward-declare it when pgtable_t must be defined before the generic > hw_pte_t typedef is visible. This avoids header-order dependencies. > > Keep the C type definitions behind an __ASSEMBLY__ check because > architecture assembly sources can include this header indirectly. Include > asm/page.h so consumers such as linux/vmalloc.h retain the page definitions > they previously obtained from that header. > > Acked-by: David Hildenbrand (Arm) <[email protected]> > Signed-off-by: Muhammad Usama Anjum <[email protected]> > --- > Changes since v1: > - Name the generic wrapper structure __hw_pte_t so architectures can > forward-declare it, and explain why this is required. > - Use software PTE value terminology. > > Changes since RFC v1: > - Add the ARCH_HAS_HW_PTE_T opt-in and generic wrapper definition. > - Exclude the C type definitions from assembly sources. > - Update the description for the new opt-in model. > --- > MAINTAINERS | 1 + > include/linux/pgtable_types.h | 17 +++++++++++++++++ > mm/Kconfig | 3 +++ > 3 files changed, 21 insertions(+) > LGTM.
Acked-by: Zi Yan <[email protected]> Best Regards, Yan, Zi
