linux-trace-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH v3 07/15] hung_task: convert process/thread iterators to for_each_*_rculock
Ye Liu
[PATCH v3 15/15] security/landlock: convert thread iterator to for_each_thread_rculock
Ye Liu
[PATCH 0/3] mm/mglru: add tracepoints for scan and aging paths
Ridong Chen
[PATCH 1/3] mm/mglru: factor out lru_gen_seq_nr_pages()
Ridong Chen
[PATCH 3/3] mm/mglru: add tracepoint for inc_max_seq()
Ridong Chen
Re: [PATCH 3/3] mm/mglru: add tracepoint for inc_max_seq()
Steven Rostedt
Re: [PATCH 3/3] mm/mglru: add tracepoint for inc_max_seq()
Ridong Chen
[PATCH 2/3] mm/mglru: add tracepoint for scan_folios()
Ridong Chen
Re: [PATCH 2/3] mm/mglru: add tracepoint for scan_folios()
Steven Rostedt
Re: [PATCH 2/3] mm/mglru: add tracepoint for scan_folios()
Ridong Chen
Re: [PATCH 2/3] mm/mglru: add tracepoint for scan_folios()
sashiko-bot
Re: [PATCH 2/3] mm/mglru: add tracepoint for scan_folios()
Ridong Chen
[PATCH v2] tracing: Take trace_array reference when opening a tracer options file
Steven Rostedt
PATCH] tracing: Revert commit 5ad289336148 ("tracing: Use a single array to represent tracer options files")
Steven Rostedt
Re: PATCH] tracing: Revert commit 5ad289336148 ("tracing: Use a single array to represent tracer options files")
Steven Rostedt
[PATCH v13 00/44] guest_memfd: In-place conversion support
Ackerley Tng via B4 Relay
[PATCH v13 08/44] KVM: Provide generic interface for checking memory private/shared status
Ackerley Tng via B4 Relay
[PATCH v13 09/44] KVM: guest_memfd: Stub in ability to enable in-place shared<=>private conversion
Ackerley Tng via B4 Relay
[PATCH v13 16/44] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Ackerley Tng via B4 Relay
[PATCH v13 25/44] KVM: selftests: Rename guest_memfd{,_offset} to gmem_{fd,offset}
Ackerley Tng via B4 Relay
[PATCH v13 26/44] KVM: selftests: Add support for mmap() on guest_memfd in core library
Ackerley Tng via B4 Relay
[PATCH v13 28/44] KVM: selftests: Add helpers for calling ioctls on guest_memfd
Ackerley Tng via B4 Relay
[PATCH v13 23/44] KVM: guest_memfd: Enable INIT_SHARED on guest_memfd for x86 Coco VMs
Ackerley Tng via B4 Relay
[PATCH v13 24/44] KVM: selftests: Create gmem fd before "regular" fd when adding memslot
Ackerley Tng via B4 Relay
[PATCH v13 05/44] KVM: Enumerate support for PRIVATE memory iff kvm_arch_has_private_mem is defined
Ackerley Tng via B4 Relay
[PATCH v13 03/44] KVM: guest_memfd: Introduce per-gmem attributes, use to guard user mappings
Ackerley Tng via B4 Relay
[PATCH v13 36/44] KVM: selftests: Add helpers to pin pages with CONFIG_GUP_TEST
Ackerley Tng via B4 Relay
[PATCH v13 04/44] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
Ackerley Tng via B4 Relay
[PATCH v13 13/44] KVM: guest_memfd: Pass mapping type filter to invalidation helper
Ackerley Tng via B4 Relay
[PATCH v13 14/44] KVM: guest_memfd: Add base support for KVM_SET_MEMORY_ATTRIBUTES2
Ackerley Tng via B4 Relay
[PATCH v13 44/44] KVM: selftests: Update private memory exits test to work with per-gmem attributes
Ackerley Tng via B4 Relay
[PATCH v13 40/44] KVM: selftests: Provide common function to set memory attributes
Ackerley Tng via B4 Relay
[PATCH v13 15/44] KVM: guest_memfd: Ensure pages are not in use before conversion
Ackerley Tng via B4 Relay
[PATCH v13 32/44] KVM: selftests: Test conversion before allocation
Ackerley Tng via B4 Relay
[PATCH v13 29/44] KVM: selftests: Test basic single-page conversion flow
Ackerley Tng via B4 Relay
[PATCH v13 43/44] KVM: selftests: Update private_mem_conversions_test for in-place conversions
Ackerley Tng via B4 Relay
[PATCH v13 39/44] KVM: selftests: Provide function to look up guest_memfd details from gpa
Ackerley Tng via B4 Relay
[PATCH v13 41/44] KVM: selftests: Make TEST_EXPECT_SIGBUS thread-safe
Ackerley Tng via B4 Relay
[PATCH v13 19/44] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE
Ackerley Tng via B4 Relay
[PATCH v13 18/44] KVM: guest_memfd: Zero page while getting pfn
Ackerley Tng via B4 Relay
[PATCH v13 34/44] KVM: selftests: Test that truncation does not change shared/private status
Ackerley Tng via B4 Relay
[PATCH v13 33/44] KVM: selftests: Convert with allocated folios in different layouts
Ackerley Tng via B4 Relay
[PATCH v13 21/44] KVM: Move KVM_VM_MEMORY_ATTRIBUTES config definition to x86
Ackerley Tng via B4 Relay
[PATCH v13 12/44] KVM: guest_memfd: Always fault from guest_memfd if in-place conversion is enabled
Ackerley Tng via B4 Relay
[PATCH v13 42/44] KVM: selftests: Set up page size and alignment independently for guest_memfd
Ackerley Tng via B4 Relay
[PATCH v13 38/44] KVM: selftests: Reset shared memory after hole-punching
Ackerley Tng via B4 Relay
[PATCH v13 11/44] KVM: guest_memfd: Invalidate both SHARED and PRIVATE mappings for in-place conversions
Ackerley Tng via B4 Relay
[PATCH v13 22/44] KVM: Let userspace disable per-VM mem attributes, enable per-gmem attributes
Ackerley Tng via B4 Relay
[PATCH v13 07/44] KVM: Rename kvm_mem_is_private() to kvm_is_private_gfn()
Ackerley Tng via B4 Relay
Re: [PATCH v13 07/44] KVM: Rename kvm_mem_is_private() to kvm_is_private_gfn()
Xiaoyao Li
[PATCH v13 02/44] KVM: guest_memfd: Use kvm_mem_is_private() when populating guest_memfd memory
Ackerley Tng via B4 Relay
[PATCH v13 37/44] KVM: selftests: Test conversion with elevated page refcount
Ackerley Tng via B4 Relay
[PATCH v13 35/44] KVM: selftests: Test that shared/private status is consistent across processes
Ackerley Tng via B4 Relay
[PATCH v13 06/44] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
Ackerley Tng via B4 Relay
[PATCH v13 10/44] KVM: Consolidate private memory and guest_memfd ifdeffery in kvm_host.h
Ackerley Tng via B4 Relay
[PATCH v13 30/44] KVM: selftests: Test conversion flow when INIT_SHARED
Ackerley Tng via B4 Relay
[PATCH v13 31/44] KVM: selftests: Test conversion precision in guest_memfd
Ackerley Tng via B4 Relay
[PATCH v13 20/44] KVM: TDX: Make source page optional for KVM_TDX_INIT_MEM_REGION
Ackerley Tng via B4 Relay
[PATCH v13 17/44] KVM: guest_memfd: Return early if range already has requested attributes
Ackerley Tng via B4 Relay
[PATCH v13 01/44] KVM: guest_memfd: Optimize away conversion overheads via dead-code elimination
Ackerley Tng via B4 Relay
Re: [PATCH v13 01/44] KVM: guest_memfd: Optimize away conversion overheads via dead-code elimination
Xiaoyao Li
[PATCH v13 27/44] KVM: selftests: Add selftests global for guest memory attributes capability
Ackerley Tng via B4 Relay
Re: [PATCH v13 00/44] guest_memfd: In-place conversion support
Yan Zhao
Re: [PATCH v13 00/44] guest_memfd: In-place conversion support
Sean Christopherson
Re: [PATCH v13 00/44] guest_memfd: In-place conversion support
Ackerley Tng
Re: [PATCH v13 00/44] guest_memfd: In-place conversion support
David Hildenbrand (Arm)
[PATCH v2 0/2] tracing: Do not clean up hiter in mmiotrace read function
Steven Rostedt
[PATCH v2 2/2] tracing: Invert the logic in mmio_read() to get rid of the goto
Steven Rostedt
[PATCH v2 1/2] tracing: Do not clean up hiter in mmiotrace read function
Steven Rostedt
[PATCH RFC 00/13] rcu-tasks: let preemption outside trampolines be a quiescent state
Josef Bacik
[PATCH RFC 01/13] rcu-tasks: Add per-task trampoline nesting count
Josef Bacik
[PATCH RFC 05/13] ftrace: Mark modules hosting direct-call trampolines for Tasks RCU
Josef Bacik
[PATCH RFC 04/13] kprobes: Let Tasks RCU recognise tasks preempted in an optprobe jump window
Josef Bacik
Re: [PATCH RFC 04/13] kprobes: Let Tasks RCU recognise tasks preempted in an optprobe jump window
sashiko-bot
Re: [PATCH RFC 04/13] kprobes: Let Tasks RCU recognise tasks preempted in an optprobe jump window
Josef Bacik
[PATCH RFC 13/13] rcu-tasks: Treat preemption outside trampolines as a quiescent state
Josef Bacik
[PATCH RFC 11/13] samples: ftrace: Maintain Tasks RCU trampoline nesting in direct-call trampolines
Josef Bacik
[PATCH RFC 02/13] entry: Pass pt_regs to irqentry_exit_cond_resched()
Josef Bacik
[PATCH RFC 03/13] rcu-tasks: Hold trampoline nesting across irq-exit preemption in trampoline text
Josef Bacik
[PATCH RFC 06/13] x86/ftrace: Maintain Tasks RCU trampoline nesting in ftrace_caller
Josef Bacik
[PATCH RFC 07/13] x86/kprobes: Maintain Tasks RCU trampoline nesting in the optprobe template
Josef Bacik
[PATCH RFC 08/13] bpf, x86: Maintain Tasks RCU trampoline nesting in the BPF trampoline
Josef Bacik
[PATCH RFC 09/13] arm64: ftrace: Maintain Tasks RCU trampoline nesting in ftrace_caller
Josef Bacik
Re: [PATCH RFC 09/13] arm64: ftrace: Maintain Tasks RCU trampoline nesting in ftrace_caller
sashiko-bot
Re: [PATCH RFC 09/13] arm64: ftrace: Maintain Tasks RCU trampoline nesting in ftrace_caller
Josef Bacik
[PATCH RFC 10/13] bpf, arm64: Maintain Tasks RCU trampoline nesting in the BPF trampoline
Josef Bacik
[PATCH RFC 12/13] rcutorture: Bracket Tasks RCU readers with trampoline nesting
Josef Bacik
Re: [PATCH RFC 00/13] rcu-tasks: let preemption outside trampolines be a quiescent state
Steven Rostedt
Re: [PATCH RFC 00/13] rcu-tasks: let preemption outside trampolines be a quiescent state
Paul E. McKenney
[PATCH] tools/bootconfig: remove unused PAGE_SIZE macro
Sang-Heon Jeon
Re: [PATCH] tools/bootconfig: remove unused PAGE_SIZE macro
Google
[PATCH v6 0/6] sched: Add support for long task name
André Almeida
[PATCH v6 3/6] lib/string_kunit: Add test for copy_task_comm()
André Almeida
[PATCH v6 2/6] treewide: Replace memcpy(..., current->comm) with copy_task_comm()
André Almeida
Re: [PATCH v6 2/6] treewide: Replace memcpy(..., current->comm) with copy_task_comm()
sashiko-bot
[PATCH v6 6/6] selftests: prctl: Add test for long thread names
André Almeida
Re: [PATCH v6 6/6] selftests: prctl: Add test for long thread names
sashiko-bot
[PATCH v6 4/6] sched: Extend task command name with TASK_COMM_EXT_LEN
André Almeida
[PATCH v6 5/6] prctl: Add support for long user thread names
André Almeida
Re: [PATCH v6 5/6] prctl: Add support for long user thread names
sashiko-bot
[PATCH v6 1/6] treewide: Get rid of get_task_comm()
André Almeida
Re: [PATCH v6 1/6] treewide: Get rid of get_task_comm()
sashiko-bot
[PATCH] bootconfig: remove redundant assignment in xbc_parse_array()
Sang-Heon Jeon
Re: [PATCH] bootconfig: remove redundant assignment in xbc_parse_array()
Google
[PATCH v4 0/2] bootconfig: Fix integer overflow problems
Masami Hiramatsu (Google)
[PATCH v4 1/2] tools/bootconfig: Fix integer overflow and truncation in size checks
Masami Hiramatsu (Google)
Re: [PATCH v4 1/2] tools/bootconfig: Fix integer overflow and truncation in size checks
Sang-Heon Jeon
[PATCH v4 2/2] bootconfig: Fix integer overflow in initrd size check
Masami Hiramatsu (Google)
Re: [PATCH v4 2/2] bootconfig: Fix integer overflow in initrd size check
Sang-Heon Jeon
Re: [PATCH v4 2/2] bootconfig: Fix integer overflow in initrd size check
Google
[PATCH] tracing: uprobes: Fix slab use-after-free in filter_chain
zafir . taufik
Re: [PATCH] tracing: uprobes: Fix slab use-after-free in filter_chain
sashiko-bot
Re: [PATCH] tracing: uprobes: Fix slab use-after-free in filter_chain
Zafir Rasyidi Taufik
[PATCH v3 0/2] bootconfig: Fix integer overflow problems
Masami Hiramatsu (Google)
[PATCH v3 1/2] tools/bootconfig: Fix integer overflow and truncation in size checks
Masami Hiramatsu (Google)
Re: [PATCH v3 1/2] tools/bootconfig: Fix integer overflow and truncation in size checks
Breno Leitao
[PATCH v3 2/2] bootconfig: Fix integer overflow in initrd size check
Masami Hiramatsu (Google)
Re: [PATCH v3 2/2] bootconfig: Fix integer overflow in initrd size check
sashiko-bot
Re: [PATCH v3 2/2] bootconfig: Fix integer overflow in initrd size check
Google
Re: [PATCH v3 2/2] bootconfig: Fix integer overflow in initrd size check
Breno Leitao
Re: [PATCH v3 2/2] bootconfig: Fix integer overflow in initrd size check
Google
[PATCH v2] tools/bootconfig: Fix integer overflow in size check
Masami Hiramatsu (Google)
Re: [PATCH v2] tools/bootconfig: Fix integer overflow in size check
sashiko-bot
[PATCH] tools/bootconfig: Fix integer overflow in size check
Masami Hiramatsu (Google)
Re: [PATCH] tools/bootconfig: Fix integer overflow in size check
Google
Re: [PATCH] tools/bootconfig: Fix integer overflow in size check
sashiko-bot
Re: [PATCH] tools/bootconfig: Fix integer overflow in size check
Google
[PATCH 0/3] bootconfig: Reject unexpected data after null character and cleanups
Masami Hiramatsu (Google)
[PATCH 2/3] tools/bootconfig: Consolidate xbc_init() to error message wrapper
Masami Hiramatsu (Google)
Re: [PATCH 2/3] tools/bootconfig: Consolidate xbc_init() to error message wrapper
sashiko-bot
Re: [PATCH 2/3] tools/bootconfig: Consolidate xbc_init() to error message wrapper
Google
Re: [PATCH 2/3] tools/bootconfig: Consolidate xbc_init() to error message wrapper
Sang-Heon Jeon
Re: [PATCH 2/3] tools/bootconfig: Consolidate xbc_init() to error message wrapper
Google
[PATCH 1/3] bootconfig: Reject unexpected data after null character
Masami Hiramatsu (Google)
Re: [PATCH 1/3] bootconfig: Reject unexpected data after null character
Sang-Heon Jeon
[PATCH 3/3] bootconfig: Skip internal tree sanity checks in kernel
Masami Hiramatsu (Google)
Re: [PATCH 3/3] bootconfig: Skip internal tree sanity checks in kernel
Sang-Heon Jeon
[PATCH v4 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
Frank . Li
[PATCH v4 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
Frank . Li
Re: [PATCH v4 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
sashiko-bot
[PATCH v4 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
Frank . Li
Re: [PATCH v4 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
sashiko-bot
[PATCH v4 2/4] dmaengine: use dma_chan_name() helper to get per-channel device name
Frank . Li
Re: [PATCH v4 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
Vinod Koul
[PATCH v2] rust: add mark_used macro
FUJITA Tomonori
Re: [PATCH v2] rust: add mark_used macro
FUJITA Tomonori
Re: [PATCH v2] rust: add mark_used macro
Alice Ryhl
Re: [PATCH v2] rust: add mark_used macro
FUJITA Tomonori
Re: [PATCH v2] rust: add mark_used macro
Miguel Ojeda
Re: [PATCH v2] rust: add mark_used macro
FUJITA Tomonori
[PATCH v2 0/3] dmaengine: qcom: gpi: Add trace event support
Praveen Talari
[PATCH v2 1/3] dmaengine: qcom: gpi: trace: Add trace events header for Qualcomm GPI DMA
Praveen Talari
Re: [PATCH v2 1/3] dmaengine: qcom: gpi: trace: Add trace events header for Qualcomm GPI DMA
Frank Li
Re: [PATCH v2 1/3] dmaengine: qcom: gpi: trace: Add trace events header for Qualcomm GPI DMA
Praveen Talari
[PATCH v2 3/3] dmaengine: qcom: gpi: Convert dev_dbg() calls to tracepoints
Praveen Talari
Re: [PATCH v2 3/3] dmaengine: qcom: gpi: Convert dev_dbg() calls to tracepoints
sashiko-bot
Re: [PATCH v2 3/3] dmaengine: qcom: gpi: Convert dev_dbg() calls to tracepoints
Frank Li
Re: [PATCH v2 3/3] dmaengine: qcom: gpi: Convert dev_dbg() calls to tracepoints
Praveen Talari
[PATCH v2 2/3] dmaengine: qcom: gpi: Add trace event support
Praveen Talari
Re: [PATCH v2 2/3] dmaengine: qcom: gpi: Add trace event support
sashiko-bot
[PATCH] selftests/ftrace: Fix unique symbol check in kprobe_non_uniq_symbol.tc
Sven Schnelle
Re: [PATCH] selftests/ftrace: Fix unique symbol check in kprobe_non_uniq_symbol.tc
Steven Rostedt
Re: [PATCH] selftests/ftrace: Fix unique symbol check in kprobe_non_uniq_symbol.tc
Google
Re: [PATCH] selftests/ftrace: Fix unique symbol check in kprobe_non_uniq_symbol.tc
Google
[PATCH] tracing: Fix ring_buffer_read_page_size() kernel-doc
Karl Mehltretter
Re: [PATCH] tracing: Fix ring_buffer_read_page_size() kernel-doc
Vincent Donnefort
[RFC PATCH 3/3] mm/vmscan: make kswapd wakeups NUMA load-aware
Ehab Ababneh
[PATCH 00/39] mm: make VMA flag semantics explicit, eliminate VM_SPECIAL
Lorenzo Stoakes (ARM)
[PATCH 01/39] mm/vma: predicate setting mmap_prepare VMA fields on new vma alloc
Lorenzo Stoakes (ARM)
Re: [PATCH 01/39] mm/vma: predicate setting mmap_prepare VMA fields on new vma alloc
sashiko-bot
[PATCH 02/39] mm/vma: introduce and use vma_[flags_]can_merge()
Lorenzo Stoakes (ARM)
Re: [PATCH 02/39] mm/vma: introduce and use vma_[flags_]can_merge()
sashiko-bot
[PATCH 04/39] mm/vma: ensure mmap_prepare doesn't set actions on a mergeable vma
Lorenzo Stoakes (ARM)
Re: [PATCH 04/39] mm/vma: ensure mmap_prepare doesn't set actions on a mergeable vma
sashiko-bot
[PATCH 08/39] docs: filesystems: update mmap_prepare docs for discontig kernel pgs
Lorenzo Stoakes (ARM)
Re: [PATCH 08/39] docs: filesystems: update mmap_prepare docs for discontig kernel pgs
sashiko-bot
[PATCH 23/39] mm/mlock: eliminate weird VMA_IO_BIT abuse and simplify
Lorenzo Stoakes (ARM)
Re: [PATCH 23/39] mm/mlock: eliminate weird VMA_IO_BIT abuse and simplify
sashiko-bot
[PATCH 09/39] drivers/usb/mon: update to use mmap_prepare + map kernel pages
Lorenzo Stoakes (ARM)
Re: [PATCH 09/39] drivers/usb/mon: update to use mmap_prepare + map kernel pages
sashiko-bot
Re: [PATCH 09/39] drivers/usb/mon: update to use mmap_prepare + map kernel pages
Greg Kroah-Hartman
[PATCH 24/39] mm/vma: enforce that only kernel-owned mappings may set VMA_IO_BIT
Lorenzo Stoakes (ARM)
Re: [PATCH 24/39] mm/vma: enforce that only kernel-owned mappings may set VMA_IO_BIT
sashiko-bot
[PATCH 06/39] mm/vma: tidy up map kernel pages enum values
Lorenzo Stoakes (ARM)
Re: [PATCH 06/39] mm/vma: tidy up map kernel pages enum values
sashiko-bot
[PATCH 25/39] mm: remove VMA_IO_BIT check in vma[_flags]_is_kernel_owned()
Lorenzo Stoakes (ARM)
Re: [PATCH 25/39] mm: remove VMA_IO_BIT check in vma[_flags]_is_kernel_owned()
sashiko-bot
[PATCH 14/39] mm/vma: add vma[_flags]_is_kernel_owned() predicates
Lorenzo Stoakes (ARM)
Re: [PATCH 14/39] mm/vma: add vma[_flags]_is_kernel_owned() predicates
sashiko-bot
[PATCH 26/39] mm: remove hugetlb_inline.h
Lorenzo Stoakes (ARM)
Re: [PATCH 26/39] mm: remove hugetlb_inline.h
sashiko-bot
[PATCH 28/39] mm: drop some redundant checks around hugetlb VMAs
Lorenzo Stoakes (ARM)
Re: [PATCH 28/39] mm: drop some redundant checks around hugetlb VMAs
sashiko-bot
Re: [PATCH 28/39] mm: drop some redundant checks around hugetlb VMAs
Marc Zyngier
[PATCH 10/39] infiniband: update hfi1 to use remap_vmalloc_range()
Lorenzo Stoakes (ARM)
Re: [PATCH 10/39] infiniband: update hfi1 to use remap_vmalloc_range()
sashiko-bot
[PATCH 13/39] bpf: arena: mark arena_map_mmap() mappings VM_MIXEDMAP
Lorenzo Stoakes (ARM)
Re: [PATCH 13/39] bpf: arena: mark arena_map_mmap() mappings VM_MIXEDMAP
sashiko-bot
[PATCH 29/39] mm/madvise: update is_valid_guard_vma() to use vma_can_merge()
Lorenzo Stoakes (ARM)
Re: [PATCH 29/39] mm/madvise: update is_valid_guard_vma() to use vma_can_merge()
sashiko-bot
Earlier messages
Later messages