On Sat, Jun 4, 2016 at 6:25 PM, John Kane <jrkrid...@gmail.com> wrote:
> Following up on my last post
> john@john-K53U:~$  sudo apt-get check
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> You might want to run 'apt-get -f install' to correct these.
> The following packages have unmet dependencies:
>  libreoffice-core : Depends: libreoffice-common (> 1:5.1.2) but it is not
> installed
>  libreoffice-java-common : Depends: libreoffice-common (= 1:5.1.2-0ubuntu1)
> but it is not installed
>  libreoffice-style-elementary : Depends: libreoffice-common (=
> 1:5.1.2-0ubuntu1) but it is not installed
>  libreoffice-style-galaxy : Depends: libreoffice-common (= 1:5.1.2-0ubuntu1)
> but it is not installed
> E: Unmet dependencies. Try using -f.
> john@john-K53U:~$
>
>


> john@john-K53U:~$  apt-get -f install
> E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission
> denied)
> E: Unable to lock the administration directory (/var/lib/dpkg/), are you
> root?
> john@john-K53U:~$  apt-get -f install lyx
> E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission
> denied)
> E: Unable to lock the administration directory (/var/lib/dpkg/), are you
> root?
> john@john-K53U:~$
>
> At the moment I cannot even remove Ly and the message (essentially the same
> as above) seems totally nonsensical.
>
Are you root? These should be run under root or with sudo.

Liviu



> n@john-K53U:~$ sudo apt-get remove lyx
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> You might want to run 'apt-get -f install' to correct these:
> The following packages have unmet dependencies:
>  libreoffice-core : Depends: libreoffice-common (> 1:5.1.2) but it is not
> going to be installed
>  libreoffice-java-common : Depends: libreoffice-common (= 1:5.1.2-0ubuntu1)
> but it is not going to be installed
>  libreoffice-style-elementary : Depends: libreoffice-common (=
> 1:5.1.2-0ubuntu1) but it is not going to be installed
>  libreoffice-style-galaxy : Depends: libreoffice-common (= 1:5.1.2-0ubuntu1)
> but it is not going to be installed
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
> a solution).
> john@john-K53U:~$
>
> Any suggestions would gratefully received.
>
>
>
>
> On 2 June 2016 at 14:34, John Kane <jrkrid...@gmail.com> wrote:
>>
>> "Never seen such a case."
>> Reminds me of the time the doctor checking the internet when I was seeing
>> him :)
>>
>> john@john-K53U:~$ sudo apt-get check
>> [sudo] password for john:
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>>
>>
>> Somehow I was expecting something a bit more dramatic.
>>
>> Synaptic is reporting 0 broken packages.
>>
>> What would you think of burning a new CD of Ubuntu 16.04 and doing a new
>> clean install?
>>
>> On 2 June 2016 at 13:27, Kornel Benko <kor...@lyx.org> wrote:
>>>
>>> Am Donnerstag, 2. Juni 2016 um 12:59:39, schrieb John Kane
>>> <jrkrid...@gmail.com>
>>> > I was beginning to suspect that. Any suggestions?
>>>
>>> No. Never seen such a case. I for one get
>>>         # dpkg -p libqtcore4:amd64
>>> Package: libqtcore4
>>> Priority: optional
>>> Section: libs
>>> Installed-Size: 5053
>>> Maintainer: Kubuntu Developers <kubuntu-de...@lists.ubuntu.com>
>>> Architecture: amd64
>>> Multi-Arch: same
>>> Source: qt4-x11
>>> Version: 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
>>> Depends: qtcore4-l10n, libc6 (>= 2.15), libgcc1 (>= 1:4.1.1),
>>> libglib2.0-0 (>= 2.22.0), libstdc++6 (>= 4.6), zlib1g (>= 1:1.1.4)
>>> Pre-Depends: multiarch-support
>>> Suggests: libicu48, libthai0
>>> Size: 1554504
>>> Description: Qt 4 core module
>>>  Qt is a cross-platform C++ application framework. Qt's primary feature
>>>  is its rich set of widgets that provide standard GUI functionality.
>>>  .
>>>  The QtCore module contains core non-GUI functionality.
>>> Homepage: http://qt-project.org/
>>> Original-Maintainer: Debian Qt/KDE Maintainers
>>> <debian-qt-...@lists.debian.org>
>>> ...
>>>
>>> Try to check your packages
>>>         # sudo apt-get check
>>> or
>>>         # sudo synaptic
>>> and try to identify broken packages.
>>>
>>>         Kornel
>>
>>
>>
>>
>> --
>> John Kane
>> Kingston ON Canada
>
>
>
>
> --
> John Kane
> Kingston ON Canada



-- 
Do you think you know what math is?
http://www.ideasroadshow.com/issues/ian-stewart-2013-08-02
Or what it means to be intelligent?
http://www.ideasroadshow.com/issues/john-duncan-2013-08-30
Think again:
http://www.ideasroadshow.com/library

Reply via email to