On Friday 07 August 2009 02:58:32 pm Piero wrote:
> Julio Rojas <jcredbe...@...> writes:
> > Everything is in the same folder. Lyx can read the file and shows the
> > references when I select them, so no, I believe this is not the
> > problem. You can see the bibliography declared in the lines I
> > provided:
> >
> > \bibliography{biblatex-apa-test-references}
> >
> > I'm working right now in Ubuntu 9.04, but I also work in XP and Leopard.
>
> Ooops, didn't see the line, sorry.
>
> Anyway, BibLaTeX doesn't work with me without the FULL PATH, and PDF only
> show bibtex keys. Tried already?

I had this problem a while ago, and solved it by always giving the full path 
to the bib files in the preamble. If I remember correctly, the problem has to 
do with LyX's compilation strategy. To produce a pdf file, Lyx first produces a 
.tex file in a temporary directory, and then runs (pdf)latex on it. At that 
point, latex can no longer find the .bib database because it is no longer in 
the same directory as the .tex file.

Have you tried exporting your .lyx  file to a  latex (.tex) file and then 
running (pdf)latex on it from the command line? If I am right, it should 
produce correct references while the "View>PDF" command in Lyx (which uses the 
strategy above) shouldn't. Looking at the full Latex log (Document>Latex log) 
can be helfpul too.


Cheers,

Stefano

______________________________________________________________
Stefano Franchi
Department of Philosophy          Ph:  (979) 862-2211
Texas A&M University              Fax: (979) 845-0458
305B Bolton Hall                  fran...@philosophy.tamu.edu
College Station, TX 77843-4237

Reply via email to