On Nov 4, 2007, at 6:29 PM, Anders F Björklund wrote:
Ryan Schmidt wrote:
In follow-ups, nox and jmpp agreed that using ".diff" at the end
of the filename is a good idea. Therefore, "port lint" recommends
this.
Right, and in follow-ups I didn't... But it's not _that_ important
to me, as I'm really not used to either tradition but have normally
been using -p1 patches instead in RPM. (named something like
foo-1.2.3-bar.patch) So if it is now required, then so be it I
suppose. :-P
It's not required, but rather advised ;-) The "patch" message is
already conveyed by the "patch-*" part in the suggested file name,
and the .diff extension helps some editors handle the file better.
Overall, it's a simple thing that does not warrant too much bikeshed,
though consistency is a good thing.
Regards,...
-jmpp
_______________________________________________
macports-dev mailing list
[email protected]
http://lists.macosforge.org/mailman/listinfo/macports-dev