I think this might be progress.

Fixed the libstdc++ linking (my fault, sorta, not theirs -- had to do the 
-std=libc++  in the CXX flags that is pervasive on the LibCxxOnOlderSystems 
machine).

I note this 'platform plugin' issue was all over the 'net when 5.4 came out a 
while back, so I suspect I'll find some kind of fix eventually... so far moving 
the libqcocoa.dylib into various places in the app bundle, or setting the DYLD 
path, hasn't worked, but I have other things to try still.

I'll be mighty pleased if qt5 opens a window here one day :> I'll plug along 
for a bit with 5.4 before I skulk away to 5.3.2.

qt has configuration files all over the place, all calling each other -- what a 
maze to follow...

K

here's the output of what you suggested -- perhaps you see something there that 
I don't immediately notice...

$ otool -L /opt/local/libexec/qt/5.4/clang_64/plugins/platforms/libqcocoa.dylib
/opt/local/libexec/qt/5.4/clang_64/plugins/platforms/libqcocoa.dylib:
        libqcocoa.dylib (compatibility version 0.0.0, current version 0.0.0)
        /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa 
(compatibility version 1.0.0, current version 21.0.0)
        /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon 
(compatibility version 2.0.0, current version 157.0.0)
        /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit 
(compatibility version 1.0.0, current version 275.0.0)
        /usr/lib/libcups.2.dylib (compatibility version 2.0.0, current version 
2.11.0)
        /opt/local/libexec/qt/5.4/clang_64/lib/QtGui.framework/Versions/5/QtGui 
(compatibility version 5.4.0, current version 5.4.2)
        
/opt/local/libexec/qt/5.4/clang_64/lib/QtCore.framework/Versions/5/QtCore 
(compatibility version 5.4.0, current version 5.4.2)
        
/System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration 
(compatibility version 1.0.0, current version 1.0.0)
        /usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 
1.2.5)
        /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL 
(compatibility version 1.0.0, current version 1.0.0)
        
/System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
 (compatibility version 1.0.0, current version 48.0.0)
        /System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility 
version 1.0.0, current version 1.0.0)
        
/opt/local/libexec/qt/5.4/clang_64/lib/QtPrintSupport.framework/Versions/5/QtPrintSupport
 (compatibility version 5.4.0, current version 5.4.2)
        
/opt/local/libexec/qt/5.4/clang_64/lib/QtWidgets.framework/Versions/5/QtWidgets 
(compatibility version 5.4.0, current version 5.4.2)
        /usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 
120.0.0)
        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current 
version 1213.0.0)
        /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit 
(compatibility version 45.0.0, current version 1343.14.0)
        
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation 
(compatibility version 150.0.0, current version 1151.16.0)
        
/System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices 
(compatibility version 1.0.0, current version 62.0.0)
        /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation 
(compatibility version 300.0.0, current version 1151.16.0)
        /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 
228.0.0)
KensMacBookPro:~ cunningh$ 

_______________________________________________
macports-users mailing list
macports-users@lists.macosforge.org
https://lists.macosforge.org/mailman/listinfo/macports-users

Reply via email to