Thanks Ryan.

I have reactivated boost.

The config log is here: https://pastebin.com/VdiZHn4k 
<https://pastebin.com/VdiZHn4k>

Mike

> On Nov 6, 2019, at 12:30, Ryan Schmidt <ryandes...@macports.org> wrote:
> 
> 
> 
> On Nov 5, 2019, at 19:39, Michael Newman wrote:
> 
>> Maybe I’m just not smart enough to play with MacPorts….
> 
> Normally things work pretty well. Sometimes you'll encounter errors. 
> Unfortunately we'll have to deal with them on a case by case basis!
> 
> 
>> This on an iMac still running Mojave.
>> 
>> This morning I did selfupdate and upgrade outdated with the following result:
>> 
>> Error: mysql57 cannot be built while boost is active.
>> Error: Please forcibly deactivate boost, e.g. by running:
>> Error:
>> Error:     sudo port -f deactivate boost
>> Error:
>> Error: Then try again. You can reactivate boost again later.
>> 
>> I deactivated boost as instructed and ran upgrade outdated again.
>> 
>> This time mysql built OK, but I got:
> 
> Ok great. Don't forget to reactivate boost. (sudo port activate boost)
> 
> 
>> Error: Failed to configure postgresql84, consult 
>> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_postgresql84/postgresql84/work/postgresql-8.4.22/config.log
>> Error: Failed to configure postgresql84: configure failure: command 
>> execution failed
>> 
>> The config.log file referred to is just under 1000 lines long. Is there 
>> anything in particular I should look for?
> 
> Please show us this file. You could file a bug report in our issue tracker 
> and attach it. Or you could upload it to a paste service (perhaps 
> https://paste.macports.org ) and send us the URL.
> 

Reply via email to