I washed the seat tracks out in the solvent tank, they (all four of them)
were filthy.  I then spray-lubed the tracks with lithium grease and
reassembled the seat.  No real problem (though time-consuming) except
that while reinstalling the seat I snapped off the front handle!
Aargh!  _This_ time, at least, I have the piece, so I used Shoe
Goo to reattach it.  It should be fine.  The seat moves easily now.

Out shopping I bought a cup holder, an in-line fuel filter, and some
diesel biocide.  Time to treat the tank!  I put half in each tank.

On the test drive I tried out the now-hooked-up cruise control, and it
acts like most of the other broken (but intact) ones I've played with:
it will accelerate when you ask it to, but cannot hold a speed.

The weather this afternoon was also quite nice, so I hit the sunroof
switch.  It flew open without any trouble whatsoever.  Closing,
however, was a different story.  It binds when closing and you can
hear the motor slipping the clutch in the trunk.  When you let off the
switch you can see the roof continue to creep forward a little bit as
cable tension dissipates.  Hit the switch again and it lurches forward
a tiny bit and then binds.  Ad infinitum.  Pulling on it to help it
close does nothing, so I don't suspect a loose clutch.  I'm going to
have to open it up and go through it.  At least I've done one before.

This evening I removed the cruise control amplifier, stripped the
varnish off the back, and resoldered about half of it before I ran out
of time.  Oddly enough, the often-bad electrolytic capacitor that is a
main suspect was in great shape, so I left it in.  I slipped the
amplifier back into the car, and on its test drive the cruise control
worked.  It surged a bit, but that's main symptom #2, and probably a
sign that not all solder joints are yet good.  At least on this 240D a
surging throttle pedal is barely noticeable due to the lack of
horsepower.  Progress!

-- Jim

Reply via email to