On 09/19/16 21:00, Edgar Pettijohn wrote:
On 16-09-19 19:56:31, Kapfhammer, Stefan wrote:
Hello Edgar,

I have no Soekris, but Apu2 is also connected
with a serial cable.

When cable is plugged in the controlling pc
before booting, it is to be found as /dev/cuaU???0.

When I plug it in after the boot completed, it is to be
found as /dev/cuaU3. (0/1/2 is normally int. 3G modem)

Hope this helps debugging. Feedback would be fine.

Thanks for the reply. It has always worked with:

# cu -l cuaU0

when it stopped working I tried cuaU{1,2} with same result.

I suppose I may as well provide some dmesg porn.


Freundliche Gr????e / Regards
-stefan kapfhammer
  Originalnachricht
Von: Edgar Pettijohn
Gesendet: Montag, 19. September 2016 20:52
An: misc@openbsd.org
Betreff: cuaU0 problems


I use a usb serial cable to talk to my soekris router. That works with
6.0 release but not current.  I was hoping to find commits related to it
and roll back to find what broke it, but I'm not sure where to look.

Any help is appreciated.

Thanks,
--
Edgar Pettijohn


According to the dmesg you have:

puc0 at pci0 dev 22 function 3 "Intel 6 Series KT" rev 0x04: ports: 1 com
com4 at puc0 port 0 apic 2 int 19: ns16550a, 16 byte fifo
com4: probed fifo depth: 0 bytes

did you try cuaU3?

hth

Fred

Reply via email to