On Fri, Aug 16, 2019 at 03:38:43AM +0600, Denis Fateyev wrote:
> Hello Gilles,
> You are right, I tried "opensmtpd-6.4.2p1.tar.gz" release for some reasons,
> and it was failing to build.
> The latest checkout from portable branch is fine, and doesn't bring any
> build issues anymore, it's great!
> I will test it for a while with some use cases.
> Out of curiosity, I have also tried it with openssl-1.0.2k (RHEL7) , and as
> expected it's failing.
> Mostly related to RSA methods. Just to note:
> https://kojipkgs.fedoraproject.org//work/tasks/2547/37062547/build.log

yeah, the problem is described here:


long story short, the same code can't build for both 1.0.z and 1.1.z, to
support both requires using two different APIs.

it is technically doable but 1.0.z will be EOL a month or so after we'll
release our next major version so the work isn't worth it.

Gilles Chehade                                                 @poolpOrg

https://www.poolp.org            patreon: https://www.patreon.com/gilles

Reply via email to