On Sun, 3 Mar 2024, Omar Polo wrote:

ouch!  Don't know much of how pkgsrc works, but this seems strange.  Can
you make sure the users were created?  `grep smtp /etc/passwd' should be

Yes, both users exist. I created them with id 1012 and 1013 and they work fine with 7.3.0p2 built from a source download (ie, not from pkgsrc).
Here is the part of my /etc/passwd file with these two users:
  _smtpd:*:1012:1003:SMTP Daemon:/var/empty:/sbin/nologin
  _smtpq:*:1013:1004:SMTPD Queue:/var/empty:/sbin/nologin

Can you try passing explicitly CFLAGS and LDFLAGS instead of --with-libssl?

./configure CFLAGS='-I/home/vajda/libressl-3.8.2/local/ -I/usr/pkg' \
-Wl,-rpath,/home/vajda/libressl-3.8.2/local/lib -L/usr/pkg/lib' \
   --prefix=`pwd`/local \
   --with-path-queue=/var/spool/smtpd \
   --with-path-empty=/var/empty \
   --with-path-mbox=`pwd`/local/var/mbox \
   --with-path-socket=/var/run \

I tried that now and configure still fails with the same error:
  checking whether LibreSSL's headers match the library... no
  configure: error: Your LibreSSL headers do not match your library.


Reply via email to