On 2024/03/04 09:32:14 -0800, Andi Vajda <o...@ovaltofu.org> wrote:
> On Mon, 4 Mar 2024, Omar Polo wrote:
> > Sorry, I made a typo.  It should be
> >
> >    ./configure CFLAGS='-I/home/vajda/libressl-3.8.2/local/include/ 
> > -I/usr/pkg/include'
> >
> > I missed the /include at the end of both -I args.
> >
> > If it still doesn't work, can you please include the `config.log' file?
> > Feel free to send it off-list.
> Same error:
> ./configure CFLAGS='-I/home/vajda/libressl-3.8.2/local/include 
> -I/usr/pkg/include' LDFLAGS='-L/home/vajda/libressl-3.8.2/local/lib 
> -Wl,-rpath,/home/vajda/libressl-3.8.2/local/lib -L/usr/pkg/lib' 
> --prefix=`pwd`/local --with-path-queue=/var/spool/smtpd 
> --with-path-empty=/var/empty --with-path-mbox=`pwd`/local/var/mbox 
> --with-path-socket=/var/run --with-path-pidfile=/var/run
> checking whether LibreSSL's headers match the library... no
> configure: error: Your LibreSSL headers do not match your library.

Thanks for sharing the config.log too.

it appears that the problem is actually not related to libressl:

configure:20721: checking whether LibreSSL's headers match the library
configure:20749: gcc -o conftest -I/home/vajda/libressl-3.8.2/local/include 
-I/usr/pkg/include -Wall -Wpointer-arith -Wuninitialized -Wsign-compare 
-Wformat-security -Wsizeof-pointer-memaccess -Wno-pointer-sign 
-Wno-unused-result -fno-strict-aliasing -fno-builtin-memset -std=gnu99 
-Wl,-rpath,/home/vajda/libressl-3.8.2/local/lib -L/usr/pkg/lib conftest.c -lssl 
-lcrypto -lutil -lcrypt  -levent >&5
configure:20749: $? = 0
configure:20749: ./conftest
./conftest: Shared object "libevent-2.1.so.7" not found
configure:20749: $? = 1
configure: program exited with status 1

So the issue is that at runtime ld.so fails to load libevent2 somehow...

(by the way, do you get the same error in config.log also when using
--with-ssl?  just a curiosity of mine)

Now, I don't have experience with NetBSD unfortunately.  I'm not sure if
/usr/pkg/lib is in the deafult search path for ld.so, and I'm also not
sure if my suggestion to use -Wl,-rpath,/path/to/libressl is breaking
the lookups for other libraries in /usr/pkg/lib.

I'd start by removing -Wl,-rpath,... and see if it improves the

Reply via email to