Hello,

2018-02-22 13:41 GMT+03:00 Nikos Mavrogiannopoulos <n...@redhat.com>:
> On Thu, 2018-02-22 at 07:54 +0100, Niels Möller wrote:
>> ni...@lysator.liu.se (Niels Möller) writes:

> Thanks for bringing that up. I have a quick fix for that, although I no
> longer have such systems for checking.

Do you need one? Maybe we can buy you smth. from eBay if it's not too costly?


> seems to show gnutls (in fips140 drbg code), stoken, qemu, rdup,
> filezilla, pike, cmake, uanytun, haskell-bindings-nettle, libarchive,
> anytun, and mosh.
>
> That seems to be quite a popular API and removing it would break those
> projects. Why not keep it as backwards compatible and mark it as
> deprecated with a macro (copied from gnutls):

Dropping API is always painfull. Maybe it can be verbally deprecated now
and removed before 4.0 in future?

It is not possible to deprecate a macro. Deprecation attributes are handled
by compiler, while macros are resolved by preprocessor.

>
> #ifdef __GNUC__
> # define _GNUTLS_GCC_VERSION (__GNUC__ * 10000 + __GNUC_MINOR__ * 100 +
> __GNUC_PATCHLEVEL__)
>
> # if _GNUTLS_GCC_VERSION >= 30100
> #  define _GNUTLS_GCC_ATTR_DEPRECATED __attribute__ ((__deprecated__))
> # endif
> #endif



-- 
With best wishes
Dmitry
_______________________________________________
nettle-bugs mailing list
nettle-bugs@lists.lysator.liu.se
http://lists.lysator.liu.se/mailman/listinfo/nettle-bugs

Reply via email to