It looks like from looking the following file that there is an attempt to set 
printer_context = ‘label’ for spine label printing.

http://git.evergreen-ils.org/?p=Evergreen.git;a=blob;f=Open-ILS/xul/staff_client/server/cat/spine_labels.js#l592

I looked at another machine that has the same printer, running the same version 
of windows (7), and it also has something strange going on.  When I look at the 
label context defaults, it is set to a PDF generator/printer.  But when the 
print button is pressed, it does default to the correct printer.

It looks like it is maybe always printing to the xul default printer as 
specified by the print_printer user pref.  So it doesn’t look like the label 
context is actually used to me.

I also tried creating a new evergreen staff client profile on the machine, 
which had the same behavior as the original profile.

I think I’ll try updating the driver next to see if something is off there.

Josh Stompro - LARL IT Director

From: Open-ils-general 
[mailto:open-ils-general-boun...@list.georgialibraries.org] On Behalf Of 
Morgan, Michele
Sent: Thursday, October 05, 2017 11:21 AM
To: Evergreen Discussion Group
Subject: Re: [OPEN-ILS-GENERAL] Label Printer Context and spine labels

Hi Josh,
I haven't looked at this in a while, but have run into at least one place where 
printers configured under the contexts weren't used. This Launchpad bug is one 
example:

https://bugs.launchpad.net/evergreen/+bug/1193405
I don't know if this is an issue with label printing. You could try going to 
about:config in the client and changing "print.printer" to point to your label 
printer to see if that's the issue. That's how we worked around the problem for 
the Simplified Pull List.
Hope this helps,
Michele

--
Michele M. Morgan, Technical Support Analyst
North of Boston Library Exchange, Danvers Massachusetts
mmor...@noblenet.org<mailto:mmor...@noblenet.org>


On Thu, Oct 5, 2017 at 10:58 AM, Josh Stompro 
<stomp...@exchange.larl.org<mailto:stomp...@exchange.larl.org>> wrote:
Hello, I’ve been having some problems setting up a spine label printer on one 
computer.

Even though I go into the workstation printer settings editor and set the 
correct printer as the default printer for the label context, whenever I press 
the print page button on the spine label preview and print page, it aways 
defaults to sending the print job to the windows default printer.  When I look 
at the config files in the client profile directory, it looks like the 
different printer contexts are setup correctly.  We are running eg 2.10.6 right 
now.

Has anyone run into this before?  I about ready to delete the client profile 
and try setting it up again, but I thought I would ask first.

Thanks
Josh

Lake Agassiz Regional Library - Moorhead MN larl.org<http://larl.org>
Josh Stompro     | Office 218.233.3757 EXT-139<tel:(218)%20233-3757>
LARL IT Director | Cell 218.790.2110<tel:(218)%20790-2110>


Reply via email to