After sending this message I thought of one other critical difference between 
the selfcheck and administrator logins.  We have openkiosk set to run directly 
as the shell, so explorer doesn't run.  And that seems to be the culprit.  When 
I launch openkiosk from the normal explorer shell, then the printing works 
fine, with no delay before cut.  So I think this is solved.  Sorry about the 

Josh Stompro - LARL IT Director

From: Open-ils-general 
[] On Behalf Of Josh 
Sent: Friday, November 03, 2017 8:53 AM
Subject: [OPEN-ILS-GENERAL] Star receipt printer , self check, pause before cut

This sender failed our fraud detection checks and may not be who they appear to 
be. Learn about spoofing<>


Hello, I'm curious if anyone has run into this and found a solution for it.

We use Star TSP100 and TSP600 receipt printers.  Our self check machines use 
the web based self check interface.  We use the openkiosk browser to serve up 
the self check interface on our machines.

When I'm logged in as administrator and test out the self check printing a 
receipt, the receipt prints and cuts all at once.

But when using a non privileged user to run openkiosk, there is a 2 second 
delay at the end of the receipt, before the paper gets cut.  This causes users 
to try and tear out the receipt before it cuts, which sometimes messes up the 
printer, causing future prints to misfeed back into the printer.  It seems like 
the printer is waiting for more input before it times out and initiates a cut.

I've tried giving the selfcheck user profile full permissions to the printer, 
no change.  I've tried putting the selfcheck user in the administrator group, 
no change.

Has anyone run into something like this?

Lake Agassiz Regional Library - Moorhead MN
Josh Stompro     | Office 218.233.3757 EXT-139
LARL IT Director | Cell 218.790.2110

Reply via email to