Matthew Schumacher wrote:
> Mike Christie wrote:
>>>> I found another issue:  When using open-iscsi-2.0_869.2 on
>>>> everything works as described above.  You can restart iscsid and all is
>>>> well.  If I switch to open-iscsi-2.0_871_2 
>>> Where did you get 871.2? There is only a 871 on
>>> I think I can hit this. The problem seems to be we are trying to bind a 
>>> session when we should not be. I will make a up a patch for testing.
>> The problem I am seeing only occurs if you have do not have a record 
>> when you restart iscsid. In this case, we will use the settings in 
>> sysfs, but this also includes the local ip address. For software iscsi 
>> we cannot bind by ip address, and we will try to set up the offload 
>> stuff, so we either fail to reconnect or we might fail in a crazier way.
> Your right, it's just plain 871.  I must have put the .2 on because of
> 869.2.  Anyway, I doubt this is a problem in the user space because I
> can use iscsid from either version just fine as long as I use the
> modules from 869.2.  If I use the modules and user space from 871 then
> restarting iscsid causes a lost connection.

I just tried that combo and it worked for me.

Could you try all 871 stuff, and run iscsid like this

iscsid -d 8 -f &

This will redirect lots of log output to the console. Can you send that?

You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to