OK, just to close the loop on this.
 
After making the
adjustments to the correct set of ini files(ugh); the issue appears to be
resolved.
it turns out, it
wasn't the max_listens_per region.. but in fact Was the
max_listens_per_script.  The default is set to 64 (I believe).
 I set it to 0 so as to not impose any limitations and Voilà .. it's
fixed!
I want to thank everyone who took the time to
respond...  it is much appreciated!
Kind Regards,

Karl
>

>

>

> This dump is after the issue presents itself and it's not showing
any

> scripts waiting for load.  That's what is really strange.
 They

> all work perfectly for an underterminate amount of time then, a
random

> subset of them just stop.

> I will point out that when I adjusted

> the max_listens_per_script & max_listens_per_region,
I

> adjusted the ini files for a different region (smacks myself in the
head)

> so I just finished adjusting the correct files and am not restarting
the

> simulator.  We'll see if that takes care of it.

> Also, what's

> the word on increasing the MaxThreads setting from 100 to lets
say

> 300 ...  Could that setting be imposing some sort of limitation
and

> would adjusting it up cause any unexpected negative side

> effects?

> Kind Regards,

> Karl

>> Hi Karl,

>

>>

>

>> When this stops working, can you check the xengine status in
the

> console?

>

>> I see the results you have included here, but is this before
or

> after

>

>> the communication stops?

>

>>

>

>> We had a similar issue back in December on 3rd Rock Grid and
when

> things

>

>> stopped working, checking the xengine status would always show

> scripts

>

>> waiting for load.

>

>> Can you see if this is the case for you? When this stops
working

> does

>

>> xengine status show scripts waiting for load?

>

>> If so, I can share the steps we took to correct our issues
which

> might

>

>> work for you as well.

>

>>

>

>> Additionally, which version of opensim are you running?

>

>>

>

>> ~Butch

>

>>

>

>>

>

>> On 6/1/2015 11:35 AM, Karl Dreyer wrote:

>

>>>

>

>>> Hello everyone... I have a member that is experiencing a

> strange

>

>>> issue. He has server and client modules (in world prims
using

>

>>> llRegionSay & llRegionSayTo to communicate commands to

> "client"

>

>>> prims). When the simulator is restarted, all works properly
as

>

>>> expected BUT then, after what seems to be a random length of
time

> it

>

>>> seems that communcations on the sim cease to function.
i.e.

> It's

>

>>> almost as if the llRegionSay & llRegionSayTo cease to
work

> properly.

>

>>> the client prims aren't receiving the messages from the

> servers.

>

>>> What makes this even more strange is that it doesn't happen
with

> all

>

>>> of them and the prims being effected is random.. in other
words,

> an

>

>>> hour after the sim is restarted (for example) a subset of
the

> servers

>

>>> are failing to properly send messages but the subset of

> scripts

>

>>> effected seems to be different each time.

>

>>>

>

>>> I have had my resident go through and confirm that channel

> settings

>

>>> are set correctly and that there is no channel confusion
or

> conflicts

>

>>> ... the scripts themselves seem to be OK. I also had him
test

> this

>

>>> system on a blank sim or a sim with considerably less scripts
and

> the

>

>>> system works flawlessly.

>

>>>

>

>>> My first thought was that there was an issue with the
listeners

> in the

>

>>> receiving prims and we're hitting some sort of imposed limit
to

> the

>

>>> number of listeners or listener events allowed on a region.
I

> found

>

>>> in the OpenSimDefaults.ini file that there is in fact a

>

>>> max_listens_per_region setting and a
max_listens_per_script

> setting.

>

>>> My first inclination was that he was hitting one of these
limits

> so,

>

>>> I modified these settings to 0 so that the system would
not

> impose any

>

>>> limits and unfortunately, this did not fix the issue.

>

>>>

>

>>> Is there somewhere else in the ini files or hardcoded in
the

> simulator

>

>>> code itself where a limitation is being set? If not, what
else

> could

>

>>> be causing this behavior?

>

>>>

>

>>> Below is a dump of some of the relevant statistics for the
region

> in

>

>>> question. Any assistance would be greatly appreciated.

>

>>>

>

>>> CONNECTION STATISTICS

>

>>> Client logouts due to no data receive timeout: 0

>

>>> SAMPLE FRAME STATISTICS

>

>>> Dilatn SimFPS PhyFPS AgntUp RootAg ChldAg Prims AtvPrm
AtvScr

>

>>> ScrLPS

>

>>> 1.00 54 53.8 0.0 0 0 6623 0 1760

>

>>> 5

>

>>> PktsIn PktOut PendDl PendUl UnackB TotlFt NetFt PhysFt
OthrFt

>

>>> AgntFt

>

>>> ImgsFt

>

>>> 15 24 0 0 0 19.1 0.0 0.0 0.0 0.0

>

>>> 0.0

>

>>> MEMORY STATISTICS

>

>>> Heap allocated to OpenSim : 645 MB

>

>>> Last heap allocation rate : 0.323 MB/s

>

>>> Average heap allocation rate: 0.202 MB/s

>

>>> Process memory : 1270 MB

>

>>> Status of XEngine instance

>

>>> Scripts loaded : 1760

>

>>> Scripts waiting for load : 0

>

>>> Max threads : 100

>

>>> Min threads : 2

>

>>> Allocated threads : 12

>

>>> In use threads : 2

>

>>> Work items waiting : 0

>

>>> Events queued : 0

>

>>> Events processed : 214185

>

>>> Sensors : 8

>

>>> Dataserver requests : 0

>

>>> Timers : 46

>

>>> Listeners : 61

>

>>>

>

>>>

>

>>>

>

>>> _______________________________________________

>

>>> Opensim-users mailing list

>

>>> Opensim-users@opensimulator.org

>

>>>

> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

>

>>

>

>> _______________________________________________

>

>> Opensim-users mailing list

>

>> Opensim-users@opensimulator.org

>

>>
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

>

>>

>

>

>

>

>

> ___________________________

>

> Karl M. Dreyer Jr.

>

> In World Avi : Damean Paolino

>

> Island Oasis, LLC Co-Founder | CIO

>

> http://www.islandoasis.biz

>

>

>

> Notice: The contents of this email and any files transmitted with it
are

> confidential and intended solely for the individual or entity to whom
it

> is addressed. The content of this email message is not to be
disclosed,

> copied, distributed, or shared with any person(s) or entities without
the

> express consent of the sender. This message contains confidential

> information and is intended only for the individual named.

>





___________________________

Karl M. Dreyer Jr.

In World Avi : Damean Paolino

Island Oasis, LLC Co-Founder | CIO

http://www.islandoasis.biz



Notice: The contents of this email and any files transmitted with it are
confidential and intended solely for the individual or entity to whom it
is addressed. The content of this email message is not to be disclosed,
copied, distributed, or shared with any person(s) or entities without the
express consent of the sender. This message contains confidential
information and is intended only for the individual named.
_______________________________________________
Opensim-users mailing list
Opensim-users@opensimulator.org
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

Reply via email to