Hi Wouter,

On Mon, Dec 14, 2009 at 9:07 AM, Wouter Boelen <li...@wboelen.be> wrote:
> Yep, that seems to be it. I'm going to replace "OperationQueue" with  
> "std::list< ref_ptr<Operation> >"  as a temporary fix.

The code in the OSG is technically correct, as the OperationQueue
typedef is within the GraphicsContext scope, so this does look like a
Borland scoping bug.

However, have a class and typedef named the same thing, even in
slightly different scope is not elegant, and is pretty easy to fix.
Try just renaming the GraphicsContext typedef from OperationQueue to
GraphicsOperationQueue.  I'm making this change in my own check out of
svn/trunk right now and once I get a clean build will check this
change in.

Robert.
_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Reply via email to