Hi.
I have problem running minimal OSG application under Android.
Here's the full source code for Android Studio 2.2 with prebuilt x86 and
armeabi-v7a OSG libraries:
https://bitbucket.org/kornerr/android-openscenegraph/src
The OSGApp with initialization and rendering:
https://bitbucket.org/kornerr/android-openscenegraph/src/tip/app/src/main/cpp/src/OSGApp.cpp?at=default&fileviewer=file-view-default

I've added logs to locate the exact line of code that crashes.
Here's the log:

I/OSGLog: init
I/OSGLog: got init
D/EGLview: Renderer.onDrawFrame
I/OSGLog: begin step
I/OSGLog: 01. frame
E/eglCodecCommon: glUtilsParamSize: unknow param 0x00008073
E/eglCodecCommon: glUtilsParamSize: unknow param 0x000088ff
I/OSGLog: 1. renderingTraversals
I/OSGLog: 01. GC.runOperations
I/OSGLog: 01. Renderer.operator()
I/OSGLog: 01. Renderer.cull_draw
I/OSGLog: 01.SceneView.cull
I/OSGLog: 01.SceneView.cullStage
I/OSGLog: 01.CullStack.pushProjectionMatrix
I/OSGLog: _projectionStack.size: 0
I/OSGLog: matrix: 0x2a1b5bb8
I/OSGLog: 02.CullStack.pushProjectionMatrix
I/OSGLog: 02.SceneView.cullStage
I/OSGLog: 02.SceneView.cull
I/OSGLog: 02. Renderer.cull_draw
I/OSGLog: 02. Renderer.operator()
I/OSGLog: 02. GC.runOperations
I/OSGLog: 2. renderingTraversals
I/OSGLog: 02. frame
I/OSGLog: finish step
D/EGLview: Renderer.onDrawFrame
I/OSGLog: begin step
I/OSGLog: 01. frame
I/OSGLog: 1. renderingTraversals
I/OSGLog: 01. GC.runOperations
I/OSGLog: 01. Renderer.operator()
I/OSGLog: 01. Renderer.cull_draw
I/OSGLog: 01.SceneView.cull
I/OSGLog: 01.SceneView.cullStage
I/OSGLog: 01.CullStack.pushProjectionMatrix
I/OSGLog: _projectionStack.size: 0
I/OSGLog: matrix: 0x2a1b4f70
A/libc: @@@ ABORTING: INVALID HEAP ADDRESS IN dlfree addr=0x5218a4a4
A/libc: Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 655
(Thread-72)
Application terminated.

The application crashes at
https://github.com/openscenegraph/OpenSceneGraph/blob/master/src/osg/CullStack.cpp#L159
when frame() is executed the SECOND time, the first frame() execution is
fine.

I observe standard purple screen for a second, then the application crashes.

I'm stuck. Any idea?
_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Reply via email to