HI Chris,

On 10 August 2017 at 02:11, Chris Kuliukas <ch...@kuliukas.com> wrote:

> The problem is whenever I try to use
>     gc->getState()->setUseModelViewAndProjectionUniforms(true);
>     gc->getState()->setUseVertexAttributeAliasing(true);
> it always seems to screw up something, like the precipitation or particle
> effects.
>

This sounds like a bug somewhere.  Could you be specific so we can see if
we can reproduce the problem and then hunt down and resolve it.


> I figure if there is a way I can set the projection matrices etc to new
> variables, instead of overwriting existing gl_whatever variables in
> shaders, then I can supply my shaders with the data they need without
> affecting anything else.
>

There is currently a transition between old fixed function, early GLSL and
new GLSL, the introduction of the attribute and built uniform aliasing is
part of this transition.  The OSG has to go wholly over to supporting the
new GLSL standards so the osg_ uniforms is the way forward.

What specifically is at issue for you is not possible to say as we really
don't have enough to go on, attempting to allow local workarounds for the
problems you are seeing isn't a good long term solution for you or for us
(the more non standard stuff you do locally the less able we are to support
you,)

Robert.
_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Reply via email to