> On Dec 1, 2016, at 3:44 PM, Ben Pfaff <b...@ovn.org> wrote:
> On Thu, Dec 01, 2016 at 01:09:12PM -0800, Jarno Rajahalme wrote:
>>> If I may be permitted to nit-pick, the name "modify_forward_counts" took
>>> me a bit of thinking to properly understand.  Maybe "modify_keep_stats"
>>> would be easier for me to understand at first glance.
>> “stats” include the last used timestamp, which is treated
>> independently of the byte and packet counts. How about
>> “modify_keep_counts”?
> Sure.

Pushed to master and branch-2.6.

Backported the earlier used-timestamp fix to branch-2.5, and squashed in a fix 
for that patch, since it was the one introducing the reset_counts regression, 
and also squashed in the new test case to verify behavior on branch-2.5. 
Branch-2.5 is OK apart from a difference in reported packet size (54 vs. 60 
bytes). Since that difference is unrelated, I modified the test case and pushed 
the result to branch-2.5.


dev mailing list

Reply via email to