------- You are receiving this mail because: ------- You are on the CC list for the bug.
http://bugs.exim.org/show_bug.cgi?id=1049 --- Comment #22 from Philip Hazel <[email protected]> 2011-11-15 09:58:33 --- On Tue, 15 Nov 2011, Zoltan Herczeg wrote: > I am still thinking about whether we need two header files. In C we can define > functions without actually implement them. Thus we could have one header with > all function prototypes. Indeed. > And if we would introduce a macro which appends _16 to all _pcre symbols with > ## preprocessor directive, we could build both libraries in the same time. > That > would be the most convenient way, perhaps. I remembered last night that I did not suggest pcre_compile16 as a name, but rather pcre16_compile. So we don't have an ugliness with pcre16_compile2 at all. It isn't really a big issue, but I think the two sets pcre_compile pcre16_compile pcre_exec pcre16_exec etc. is a bit neater than pcre_compile pcre_compile_16 pcre_exec pcre_exec_16 In an alphabetic listing all the pcre16's would sort together. Philip -- Configure bugmail: http://bugs.exim.org/userprefs.cgi?tab=email -- ## List details at https://lists.exim.org/mailman/listinfo/pcre-dev
