------- You are receiving this mail because: ------- You are on the CC list for the bug.
http://bugs.exim.org/show_bug.cgi?id=1049 --- Comment #23 from Zoltan Herczeg <[email protected]> 2011-11-15 11:31:30 --- > I remembered last night that I did not suggest pcre_compile16 as a name, > but rather pcre16_compile. So we don't have an ugliness with > pcre16_compile2 at all. It isn't really a big issue, but I think the two > sets > > pcre_compile pcre16_compile > pcre_exec pcre16_exec > etc. > > is a bit neater than > > pcre_compile pcre_compile_16 > pcre_exec pcre_exec_16 True. But my suggestion refered to the private functions which starts with _pcre prefix I mentioned above. We could rename them as well, but I feel it is too much work for little gain. Valgrind uses VG_() macro for calling or defining functions, so you have VG_(printf) and call it with VG_(printf)(...). I think this is useful for internal stuff. For public API, especially if we list the functions in one header file, we could go for really nice names. -- Configure bugmail: http://bugs.exim.org/userprefs.cgi?tab=email -- ## List details at https://lists.exim.org/mailman/listinfo/pcre-dev
