On 9/19/06, Aaron Sherman <[EMAIL PROTECTED]> wrote:
This was a minor side-comment. Let's stay focused and not rat-hole on
our respective definitions of "list transform".
Fair enough. Sorry for the distraction. To return to the topic at
hand (STAY ON TARGET! STAY ON TARGET!), so far we have these
suggestions for "grep".
1. grep (it ain't broke, so don't fix it)
2. where (by analogy with the keyword)
3. filter (descriptive and, according to Damian, a CS Standard. Not
that I recall using that
term in any of my classes, but I'll take his word for it... :))
4. select (the Rubyometer was feeling neglected)
Along with these mix-ins:
A. allow grep as an alias for whatever new name (TMTOWTSI, S=spell)
B. no aliases nohow (There Can Be Only One)
C. compromise between A and B: allow user to request aliases of various flavors,
including Perl5 (All's Fair if you Predeclare)
I have no horse in this race. My personal preference would be to
leave grep as "grep". My second choice is "select", which to me is
more descriptive than "filter"; it also readily suggests an antonym of
"reject" to do a "grep -v" (cf. "if !" vs "unless"). But I'd accept
I definitely vote C, though. No aliases in the core, but no reason
not to include modules in the standard set that provide some.
Mark J. Reed <[EMAIL PROTECTED]>