At 6:26 AM +0200 9/19/06, Damian Conway wrote:
The standard--and self-explanatory--CS term for this operation has always been "filter", which is also currently used by Python, Scheme, Haskell, and numerous other languages, so *if* we're going to change it from "grep", we ought to change it to "filter".
I agree. So "filter" is now my preference for a new name, and if "grep" is kept, then that can be an alias for it; "filter" should be the canonical name for most documentation, though. -- Darren Duncan