We have gone to a great deal of trouble to remove homonyms (such as
"eval"/"eval","select"/"select","do"/"do"/"do") from Perl 6, so I
would be very unhappy to see us create a new one by re-using "where"
to mean two different things.

I don't object in principle to renaming "grep" to something more self
explanatory (except for the further loss of backwards compatability
and historical Unix reference...though that didn't stop us with
"switch" vs "given" ;-)

The standard--and self-explanatory--CS term for this operation has
always been "filter", which is also currently used by Python, Scheme,
Haskell, and numerous other languages, so *if* we're going to change
it from "grep", we ought to change it to "filter".


Reply via email to