Oh, here's a thought ...

In signal processing electronics and such, filters are often/sometimes named after what they let through. For example, "high pass filter" or "low pass filter" to allow through either high or low frequencies, for example.

On that note, if this isn't causing another homonym problem, ...

How about "pass" as a new name; eg:

  @filtered = @original.pass:{ <condition> };

I don't think that this in any way suggests modifying the original.

-- Darren Duncan

Reply via email to